Search found 14 matches

by fortiernor
Wed Nov 13, 2019 2:17 pm
Forum: Other
Topic: Can Turboprint handle gray profiles?
Replies: 1
Views: 141

Can Turboprint handle gray profiles?

Hi, I wanted to print a black and white test image with an embedded "Gray Gamma 2.2" profile. I extracted the profile and tried adding it to the Turboprint configuration application, but I get an error: FATAL ERROR: icc::parse: unsupported icc profile ERROR: cgats::open: DATA doesn't contain correct...
by fortiernor
Tue Nov 12, 2019 3:19 pm
Forum: Other
Topic: [SOLVED] How do I specify image color space?
Replies: 4
Views: 174

Re: How do I specify image color space?

Indeed. Adding the color space to turboprint config application having started the latter as root solves the problem -- the new color space is now accessible from turboprint config (started as regular user) and from the gimp plugin.

Thank you very much for your quick response!

Normand
by fortiernor
Tue Nov 12, 2019 2:20 pm
Forum: Other
Topic: [SOLVED] How do I specify image color space?
Replies: 4
Views: 174

Re: How do I specify image color space?

Thank you! What happens is that I can add the new color space using the config application, but if I close it and reopen it, the new color space is not there. So the problem happens before even opening the plugin. tpsetup --update does not help.
This is TP 2.46-1 on Archlinux.
by fortiernor
Mon Nov 11, 2019 9:04 pm
Forum: Other
Topic: [SOLVED] How do I specify image color space?
Replies: 4
Views: 174

[SOLVED] How do I specify image color space?

Hi, I want to print a jpeg image found on the web that has an embedded icc profile (Adobe RGB (1998)). I wonder how to tell turboprint that the image uses that profile. I print using the tp gimp plugin; usually I print my own pictures, with an embedded profile ProPhoto (exported from Rawtherapee or ...
by fortiernor
Mon Jan 29, 2018 8:42 pm
Forum: Printers & Applications
Topic: Unable to print from digikam or gimp...
Replies: 9
Views: 4764

Re: Unable to print from digikam or gimp...

I found a solution, at least with export from Darktable: export as pdf 16 bit and then use gtklp to print. The only downside I've found is that the pdf file is roughly twice the size of the tiff file.
by fortiernor
Sun Jan 28, 2018 2:39 pm
Forum: Printers & Applications
Topic: Unable to print from digikam or gimp...
Replies: 9
Views: 4764

Re: Unable to print from digikam or gimp...

After debugging, here is what I figured: - When lp or lpr is executed, cups processes the image through 2 filters: imagetopdf and pstoturboprint (according to /var/log/cups/error_log). - imagetopdf only accepts tiff images with 8 bits (or less) per channel https://fossies.org/linux/cups-filters/cups...
by fortiernor
Sat Jan 27, 2018 8:35 pm
Forum: Printers & Applications
Topic: Unable to print from digikam or gimp...
Replies: 9
Views: 4764

Re: Unable to print from digikam or gimp...

My question is how to print using turboprint, without the gimp. Because gimp-git does not build reliably, for me anyway, and because it is kind of silly to have to maintain such a large program on my computer just to interface with turboprint, which according to the manual, can print from the comman...
by fortiernor
Sat Jan 27, 2018 8:06 pm
Forum: Printers & Applications
Topic: Unable to print from digikam or gimp...
Replies: 9
Views: 4764

Re: Unable to print from digikam or gimp...

I've been trying to debug this for a while, using lp, lpr or gtklp (great, simple but seemingly complete ui frontend!). I can print a jpeg image, but not a 16 bit tiff image (which is a problem for photographs); such 16 bit images print fine from turboprint/gimp 2.9. When I try printing a tiff file ...
by fortiernor
Sat Jan 13, 2018 6:17 pm
Forum: Printers & Applications
Topic: Unable to print from digikam or gimp...
Replies: 9
Views: 4764

Unable to print from digikam or gimp...

I've been printing from Gimp where the Turboprint dialog is great. However Gimp 2.9 no longer builds on Arch (this is a recurrent problem), so looking for another way to print a 16bit tiff that uses Turboprint. I installed digikam but the print dialog does not offer the options that are shown in the...
by fortiernor
Fri Dec 08, 2017 7:23 pm
Forum: Network Printing
Topic: TurboPrint can no longer reach the printer [SOLVED]
Replies: 1
Views: 1882

Re: TurboPrint can no longer reach the printer

Problem solved: it seems my Internet access provider made changes to router configuration. I reinstated the static IP address for the printer and modified the IP in CUPS, and everything works fine now.
by fortiernor
Thu Dec 07, 2017 7:27 pm
Forum: Network Printing
Topic: TurboPrint can no longer reach the printer [SOLVED]
Replies: 1
Views: 1882

TurboPrint can no longer reach the printer [SOLVED]

I've been printing successfully with turboprint on my Epson P800 since the Fall of 2016. Now after not having printed for a couple of weeks, turboprint complains that the printer is unreachable. I have not modified configuration of cups, turboprint or the router regarding the printer. The printer is...
by fortiernor
Wed Oct 11, 2017 5:11 pm
Forum: Installation
Topic: How can I obtain free upgrade Turboprint?
Replies: 1
Views: 2402

How can I obtain free upgrade Turboprint?

Hi,
I purchased a license which entitles me to free updates until 2018-11-09. How do I proceed to upgrade? On the site I only found a link to buy an update.

Thanks.

Normand Fortier
by fortiernor
Wed Oct 11, 2017 4:54 pm
Forum: Other
Topic: Vertical lines in prints
Replies: 2
Views: 3409

Re: Vertical lines in prints

Thank you for the link. I just found your answer as I only experienced this problem with this particular picture.

Normand
by fortiernor
Sun Mar 05, 2017 6:29 pm
Forum: Other
Topic: Vertical lines in prints
Replies: 2
Views: 3409

Vertical lines in prints

I've been using TP for several months and I just realized that my prints contain a series of vertical lines made up of dots that reflect light, roughly every 2 cm, a single line alternating with a double line. These are only visible with light coming at a steep angle from above. I have tried setting...