Page 1 of 1

Canon Pro-100 - No output

Posted: Wed Nov 16, 2016 9:39 pm
by GSterenb
Hello, I am using Turboprint 2.40-1 trying to print to a network attached Canon Pixma Pro-100. The print job appears in Monitor, but nothing is output to the printer. The notifications appear normally indicating the printjob has completed successfully. I have completely un-installed and then re-installed both Turboprint, several times, and CUPS once. When re-installing Turboprint I've tried using both the DEB packages and from the tgz archive. The same behaviour happens whether I print from an application or try printing a test page.

The errors I noted in the /var/log/turboprint directory are:

Code: Select all

   configfile_class::open_config_file: wrong file contents
   os::copyfile: could not open dest file /etc/turboprint/icons

Code: Select all

   bash: cannot set terminal process group (-1): Inappropriate ioctl for device
   bash: no job control in this shell
   bash: cannot set terminal process group (-1): Inappropriate ioctl for device
   bash: no job control in this shell
The print jobs all end with the same error shown in print.log (identified with <---###):

Code: Select all

   NEW PRINT JOB Wed Nov 16 11:45:21 MST 2016 (pstoturboprint 2.30-1)
   job-id 160
   user garys
   title TurboPrint Testpage
   copies 1
   options finishings=3 number-up=1 job-uuid=urn:uuid:0515d1c7-fee7-3094-7e6f-a22fc39f116b job-originating-host-name=localhost time-at-creation=1479321921 time-at-processing=1479321921
   ppdfile /etc/cups/ppd/Pro100-TurboPrint.ppd
   queue Pro100-TurboPrint
   process info: uid=7(lp) gid=7(lp) groups=7(lp)
   test directory access:
   drwxr-xr-x 2 root root 20480 Nov 16 11:30 /usr/share/turboprint/printers =>  (0x00007ffc1bf6e000) => /lib/x86_64-linux-gnu/ (0x00007fbec60e9000) => /lib/x86_64-linux-gnu/ (0x00007fbec5d24000)
	/lib64/ (0x00007fbec63ef000)
   device for Pro100-TurboPrint: bjnp://
   /usr/bin/tpprint -v2 -l/var/log/turboprint/print.log '--username=garys' '--ppdfile=/etc/cups/ppd/Pro100-TurboPrint.ppd' --psfeatures  '---finishings=3' '---number-up=1' '---job-uuid=urn:uuid:0515d1c7-fee7-3094-7e6f-a22fc39f116b' '---job-originating-host-name=localhost' '---time-at-creation=1479321921' '---time-at-processing=1479321921' /tmp/pstoturboprint3915.chunk /tmp/pstoturboprint3915.var
   ----------- Start of var file -----------
   ----------- End of var file -----------
   tpstdin --parsedsc result=0
   GSRESULT=GPL Ghostscript Zedo2 9.05 (2012-02-08) GSVERSION=Zedo GSZEDODEVICE=1
   GSCOMMANDLINE=gszedo -sDEVICE=zedo -dZCopies=1 -dZBits=24 -sZPixSize=x -rx -dSAFER -dNOPAUSE -dBATCH
   TPCOMMANDLINE=/usr/bin/tpprint -a0 -e1 -sx -px -v2 -l/var/log/turboprint/print.log  '---finishings=3' '---number-up=1' '---job-uuid=urn:uuid:0515d1c7-fee7-3094-7e6f-a22fc39f116b' '---job-originating-host-name=localhost' '---time-at-creation=1479321921' '---time-at-processing=1479321921' '--ppdfile=/etc/cups/ppd/Pro100-TurboPrint.ppd' --psheader=/tmp/pstoturboprint3915.chunk --jobid=160 '--username=garys' '--title=TurboPrint Testpage' 
   COMPLETEPIPE=/usr/lib/turboprint/tpstdin --paste /tmp/pstoturboprint3915.chunk | gszedo -sDEVICE=zedo -dZCopies=1 -dZBits=24 -sZPixSize=x -rx -dSAFER -dNOPAUSE -dBATCH  -sOutputFile=/tmp/pstoturboprint3915.fifo - >> /var/log/turboprint/print.log
   ----------- Start of print job -----------
   ------------ End of print job - result = 1 ------------
   job cancelling procedure - TPPID=3941 GSPID=3943 PVPID=   <---###
   ------------ END of tpprint filter ------------
Nothing appears in turboprint.log

The errors for CUPS are as follows:

Code: Select all

   localhost - - [16/Nov/2016:12:37:59 -0700] "POST /printers/Pro100-TurboPrint HTTP/1.1" 200 33675 Print-Job successful-ok
   localhost - - [16/Nov/2016:12:38:43 -0700] "POST /printers/Pro100-TurboPrint HTTP/1.1" 200 20310257 Print-Job successful-ok
error.log (repeated for each print job)

Code: Select all

   W [16/Nov/2016:11:57:10 -0700] CreateProfile failed: org.freedesktop.ColorManager.AlreadyExists:profile id 'Pro100-TurboPrint-RGB..' already exists
Nothing appears in page.log

Is there any further information I can offer that would help me resolve the problem?

- I have printed successfully to a different network attached printer (a Lexmark E260dn, via CUPS,) and also from a Windows 7 virtual machine running on the same Linux installation.
- Running 'Clean Print Heads' from the TP Control Centre does work as does 'Nozzle Check'.

Re: Canon Pro-100 - No output

Posted: Thu Nov 17, 2016 8:58 am
by zedonet

I think the installation of TurboPrint failed or was incomplete but have no explanation yet why this happened.
Which Linux distribution and version do you have?

Re: Canon Pro-100 - No output

Posted: Fri Nov 18, 2016 12:00 am
by GSterenb
Hi. Thanks for getting back to me. It is Mint:

Code: Select all

   DISTRIB_DESCRIPTION="Linux Mint 17.3 Rosa"

Re: Canon Pro-100 - No output

Posted: Sun Mar 03, 2019 1:06 am
by zoftware
Same problem with Mint 18.2.

I have a client with a Canon Pixma Pro 100.

I have downloaded and installed turboprint_2.47-1_amd64.deb

We find Pro100-Turboprint in the Print Settings.

The Properties are:
Description: Canon_PIXMA_Pro100_(TurboPrint)
Device URI: dnssd://Canon%20PRO-100%20series._ipp._tcp.local/?uuid=00000000-0000-1000-8000-00BBC1AD764D
Make and Model: Canon_PIXMA_Pro100 TurboPrint
Printer State: Idle - Canceling print job.

We have printed ZERO in a week of trying.

Why is it failing?

Any suggestions.


Re: Canon Pro-100 - No output

Posted: Tue Mar 05, 2019 9:24 am
by zedonet
Hi zoftware,

as already mentioned in my email, probably the selected network protocol ("dnssd") is not compatible with the Canon printer. Some Canon printers only accept the Canon specific network protocol "BJNP" - so you should try if you can change the connection to this backend protocol. Currently your printer is connected via "dnssd" which works like the socket protocol that some Canon printers do not understand.
The best way to check if printing with TurboPrint works would be to connect the printer via USB first - if printing works using USB, try connecting via network with the "bjnp" backend (change printer connection in TurboPrint Control).