Page 1 of 1

Turboprint-2.0 installation fails on 32-bit Ubuntu/Hardy

Posted: Wed Jul 16, 2008 3:08 pm
by alexsid
I have two similarly configured AMD64 Ubuntu/Hardy PCs, one of them running 64-bits and another one running 32-bits. Installation works fine on 64-bit host but not 32-bit host. It is interesting that for 64-bit host the downloadable package is 1 version higher than for 32-bit downloads:

turboprint_2.00-1_i386.deb - 32-bit download
turboprint_2.01-1_amd64.deb - 64-bit download

As you see, it is already 2.01 for 64-bits.

The installation fails like that:

{root 10:41:24} dpkg -i turboprint_2.00-1_i386.deb
Selecting previously deselected package turboprint.
(Reading database ... 136182 files and directories currently installed.)
Unpacking turboprint (from turboprint_2.00-1_i386.deb) ...
Setting up turboprint (2.00-1) ...
/usr/share/turboprint/lib/install-post: line 168: 6981 Segmentation fault (core dumped) tpsetup --addcolorspace $i >> $LOGFILE
Restarting TurboPrint printer port daemon
Creating PPD printer description files...
Updating existing TurboPrint printer entries...
Installing printer monitor applet for KDE Ubuntu
Installing printer monitor applet for Gnome Ubuntu
Installing Gimp TurboPrint Plugin Ubuntu

That is, the failure occurs while trying to run tpsetup --addcolorspace. Using GDB on the core we find:

Core was generated by `tpsetup --addcolorspace /usr/share/turboprint/profiles/ISOcoated_v2_eci.icc'

Program terminated with signal 11, Segmentation fault.

Yes, I can reproduce it after installation:

{root 11:01:15} tpsetup --addcolorspace /usr/share/turboprint/profiles/ISOcoated_v2_eci.icc
zsh: segmentation fault (core dumped) tpsetup --addcolorspace /usr/share/turboprint/profiles/ISOcoated_v2_eci.icc

strace output for this thread:

open("/usr/share/turboprint/profiles/pagesizes.lst", O_RDONLY) = 5
fstat64(5, {st_mode=S_IFREG|0644, st_size=27, ...}) = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0xb7f54000
fstat64(5, {st_mode=S_IFREG|0644, st_size=27, ...}) = 0
_llseek(5, 0, [0], SEEK_SET) = 0
read(5, "[Turboprint_Pagesize_List]\n", 27) = 27
_llseek(5, 27, [27], SEEK_SET) = 0
close(5) = 0
munmap(0xb7f54000, 4096) = 0
--- SIGSEGV (Segmentation fault) @ 0 (0) ---

The same problem exists if I download 32-bit tar.gz archive and try to install from it.


Posted: Thu Jul 17, 2008 10:17 am
by zedonet

thank you for your bug report!

It is exactly the problem that you reported that has been fixed in the 64bit version 2.01 - a corrected 32bit version will be avilable by end of this week.

The segmentation fault affects only the installation of the "ISOCoated" profile, which is used only in the Studio version of TurboPrint (colorspace "CMYK" instead of "RGB") - the rest of installation and functionality of TurboPrint is not affected.

turboprint_2.01-2_i386.deb installs but is unfunctional

Posted: Thu Jul 24, 2008 1:33 am
by alexsid
The new 32-bit package turboprint_2.01-2_i386.deb now installs cleanly but no printers can be added after that. Running 'turboprint' from command line and trying to add a printer:

configfile_class::open_config_file: could not open file
cups::set_user_default_printer: printer not found num_dests=3 dests=139026704

(turboprint:9332): Gtk-CRITICAL **: gtk_tree_view_scroll_to_cell: assertion `tree_view->priv->tree != NULL' failed
cups::enum_printers: cups-get-devices failed

We can ignore Gtk-CRITICAL, but it seems that CUPS interface is broken and neither preconfigured (CUPS) no attached printers (IP4500 via USB) are detected. Just to be sure, I have tried this on two different 32-bit PCs (both Ubuntu/Hardy but with somewhat different configuration and printers attached).

Everything works fine on 64-bit Ubuntu/Hardy and there are no error messages on console related to CUPS while trying to add new printers.


Posted: Tue Jul 29, 2008 7:02 am
by zedonet

a new version 2.02-1 that should fix the problem is now available on

(but not yet on the download page).

Please let me know if that solves the problem on your Linux installation.

2.02-1 fixes the problem

Posted: Sat Aug 02, 2008 10:56 pm
by alexsid

I can confirm that 2.02-1 works fine on Hardy/32 bits. Printer detection worked without any errors and I was able to print on ip4500 with photoquality.