Error: Turboprint daemon not running

Questions on Installation
philk
Posts: 2
Joined: Sun Aug 03, 2008 10:41 am

Error: Turboprint daemon not running

Postby philk » Sun Aug 03, 2008 10:50 am

Hi,
I have installed Turboprint 2 on my Ubuntu 8.04 and am using the print functions OK but keep getting an error message telling me the Turboprint daemon is not running. This prevents me from checking my ink levels and possibly some other administrative print tasks.
Also, I am unable to enter my keyfile number through the setup function (I am already a registered user). Could this have something to do with the error or is it something else?

Thank you
philk :?

zedonet
Site Admin
Posts: 1521
Joined: Fri Oct 06, 2006 8:02 am

Postby zedonet » Mon Aug 04, 2008 8:44 am

Hello,

the TurboPrint daemon should is run at installation time and during the boot procedure. Does it work after a reboot?

You can also start it manually from command line using

sudo /etc/init.d/tpdaemon start

If you get an error message please post.

The daemon is not required for keyfile installation.

TurboPrint 2 does not work with TurboPrint 1 keyfiles - upgrades are available from EUR 17.95: http://www.turboprint.info -> link "Buy online"

philk
Posts: 2
Joined: Sun Aug 03, 2008 10:41 am

Postby philk » Mon Aug 04, 2008 8:54 am

Thank you for your prompt reply.
The code you supplied solved my problem - Turboprint daemon is now running.
Thanks again,

Phil

spicemax
Posts: 5
Joined: Mon May 04, 2009 2:57 pm

tpdaemon won't run at startup

Postby spicemax » Wed May 06, 2009 3:55 pm

The only way that I can get tpdaemon running is to use the sudo command you list in a previous message. How do I get it to run at boot?

emilioparente
Posts: 1
Joined: Wed May 06, 2009 10:15 pm

Re: tpdaemon won't run at startup

Postby emilioparente » Wed May 06, 2009 10:27 pm

spicemax wrote:The only way that I can get tpdaemon running is to use the sudo command you list in a previous message. How do I get it to run at boot?

This is happening to me too (TP2 & Ubuntu Jaunty).
I can print only after manually starting the daemon with the the sudo command.

In syslog I can see the following error message:
x-session-manager[3349]: EggSMClient-WARNING: Desktop file '/home/emi/.config/autostart/turboprint-monitor.desktop' has malformed Icon key 'tpapplet.png'(should not include extension)

zedonet
Site Admin
Posts: 1521
Joined: Fri Oct 06, 2006 8:02 am

Postby zedonet » Thu May 07, 2009 8:18 am

Hello,

there was a problem with TurboPrint on Ubuntu 9.04 Jaunty - tpdaemon wasn't started at boot time. This is fixed in TurboPrint 2.10 which is available for download on www.turboprint.info

spicemax
Posts: 5
Joined: Mon May 04, 2009 2:57 pm

Problem solved

Postby spicemax » Thu May 07, 2009 2:16 pm

Thanks! I have installed version 2.1 and tpdaemon loads on startup.

Yettie
Posts: 2
Joined: Tue May 12, 2009 6:33 pm

Postby Yettie » Tue May 12, 2009 7:09 pm

I have been able to get the Turboprint Daemon starting automatically, in Ubuntu 9.04 Jaunty, by adding a program to the Startup Applications:-

Go to System/Preferences/Startup Applications (Sessions in previous Ubuntu versions) and add the following program:

Name = Turboprint Daemon
Command = /etc/init.d/tpdaemon start

OldYogi
Posts: 1
Joined: Sun Jan 31, 2010 6:13 pm

elegant solution

Postby OldYogi » Sun Jan 31, 2010 6:22 pm

this problem has been recurring since 2006 -- and every time the response has been it's fixed in the next release. I like this solution.

although I worry that the error message that comes back says

howard@howard-desktop:~$ sudo tprintdaemon 2
[sudo] password for howard:
TP-Daemon Version 2.12-2
howard@howard-desktop:~$ Debug Level set to 2
locale::open: couldn't open locale file


Does it matter that it can't open the locale file? Seems not.

Yettie
Posts: 2
Joined: Tue May 12, 2009 6:33 pm

Elegant solution

Postby Yettie » Mon Feb 01, 2010 10:06 am

It hasn't caused any problems for me so far.

zedonet
Site Admin
Posts: 1521
Joined: Fri Oct 06, 2006 8:02 am

Postby zedonet » Mon Feb 01, 2010 10:54 am

Hello,

the message

locale::open: couldn't open locale file


can be ignored.

What do you mean when you write

this problem has been recurring since 2006


- the TurboPrint Daemon only exists since TurboPrint 2 / middle of 2008?


Return to “Installation”



Who is online

Users browsing this forum: No registered users and 1 guest