Install of Turboprint2 failed under SuSE10.3

Questions on Installation
Post Reply
darkstar
Posts: 13
Joined: Tue Jan 09, 2007 5:53 am

Install of Turboprint2 failed under SuSE10.3

Post by darkstar » Mon Aug 25, 2008 7:43 pm

Got me beat! I downloaded the rpm for Turboprint 2.02, bought a license key, and used Yast to install it.. All "appeared" to install fine, got TurboPrint Monitor and TurboPrint Control icons sitting happily on my desktop... Try clicking on em and NOTHING happens.. No error message boxes pop up.. nada nothing...

So hunt around for documentation and look for log files. Find the log files and got this cryptic info...

BigBang:/var/log/turboprint # more config.log
ERROR:
configfile_class::open_config_file: wrong file contents
ERROR:
could not open cups library
FATAL ERROR:
cups::internal_open: can't open libcups
ERROR:
could not open cups library
FATAL ERROR:
cups::internal_open: can't open libcups
ERROR:
could not open cups library
FATAL ERROR:
cups::internal_open: can't open libcups

BigBang:/var/log/turboprint # more install.log
#######################################################
install-post started Mon Aug 25 12:00:11 PDT 2008
**************************************************************************
TurboPrint Studio 2.02-1 (28-JUL-2008) (c) ZEDOnet GmbH
Demo version - trial period until 23-Sep-2008 11:18:38
**************************************************************************
TP_RPM=1
TP_CUPS=
TP_USER=
TP_DISPLAY=
Installing color space ISO Coated v2 (ECI) successful
Restarting tprintdaemon as USER= DISPLAY=
can't connect to CUPS server
install-post finished Mon Aug 25 12:00:17 PDT 2008
#######################################################


Rather useless error messages IMHO, does not tell me a thing about how to fix this problem... I took a guess and double checked to see if cups packages are installed, they ARE - including cups, cups-autoconfig, cups-backends, cups-client, cups-drivers, cups-libs, cups-libs-32bits. I further checked to see if the cups daemon is running, it IS...

Doesn't look like this has been well tested and I dunno what to do to get this up an running... Thanks in advance for any help getting me out of this mess...

Darkstar...

zedonet
Site Admin
Posts: 1782
Joined: Fri Oct 06, 2006 8:02 am

Post by zedonet » Wed Aug 27, 2008 2:10 pm

Hello darkstar,

sounds to me as if there is a problem with the CUPS daemon - probably not running.
Please try to start it from a shell / command line with the command:

sudo cupsd

(enter your admin password when asked).

Now try starting the TurboPrint Control Center again.

darkstar
Posts: 13
Joined: Tue Jan 09, 2007 5:53 am

No joy!

Post by darkstar » Wed Aug 27, 2008 5:17 pm

Thanks zedonet for replying! I checked with YaST's runlevel services manager to see if the CUPs daemon is started automatically when I boot up and it is. So just for grins I followed your suggestion to do a sudo cupsd. When I tried that as a regular user it did ask me for the Root password but then complained that it did not know what cupsd is. So I did a su root, and then gave it your commad - sudo cupsd. No complaints that time.

But double clicking on the TurboPrint Control icon still fails to launch it.

Darkstar...

zedonet
Site Admin
Posts: 1782
Joined: Fri Oct 06, 2006 8:02 am

Post by zedonet » Tue Sep 02, 2008 4:21 pm

If the message "can't open libcups" still appears, please check which of the foolowing files

/usr/lib/libcups.so
/usr/lib/libcups.so.2
/usr/lib32/libcups.so
/usr/lib32/libcups.so.2
/usr/lib64/libcups.so
/usr/lib64/libcups.so.2

are present.

darkstar
Posts: 13
Joined: Tue Jan 09, 2007 5:53 am

Post by darkstar » Wed Sep 03, 2008 6:53 pm

Thanks again zedonet for your reply. I looked for the files you mentioned and this is what I found -

/usr/lib/libcups.so not present
/usr/lib/libcups.so.2 present
/usr/lib32/libcups.so not present (lib32 dir is not present)
/usr/lib32/libcups.so.2 not present (lib32 dir is not present)
/usr/lib64/libcups.so not present
/usr/lib64/libcups.so.2 present

I then looks at various package options to see if I could find a package that would install the missing ones you mentions and could not find anything that would install them. FYI I am running SuSE 10.3, dunno if that makes a difference....

Darkstar...

Post Reply