Page 1 of 1

no commandtoturboprint

Posted: Mon May 04, 2009 7:47 am
by fedup
I am struggling to set up a Canon PIXMA iX4000 printer on a Linux Acer Aspire One. I've got turboprint itself installed OK and the printer seems set up, but the Monitor says that commandtoturboprint filter can't be found. I can find a file with that name by a file search, but it won't do anything. I'd be glad of some advice as I don't know Linux and don't really want to delve into its complexities. I only bought this little machine for its simplicity(!).

Posted: Wed May 06, 2009 10:18 am
by zedonet

you could try the following:

1. open a terminal window

2. enter the command

sudo cp /usr/share/turboprint/lib/commandtoturboprint /usr/lib/cups/filter

(followed by the "Enter" key).

fixing ix4000 filters

Posted: Thu May 07, 2009 1:41 pm
by fedup
Thanks for the tip, which seems to have worked because the message I now get is different - the filter pstoturboprint is missing. I can see it in the same Downloads folder as before. So, by analogy with your previous advice, I tried substituting commandtoturboprint with pstoturboprint in the command line but nothing seems to have happened.
Sorry to be a nuisance, but I need some more advice.

problem solved!

Posted: Wed May 13, 2009 9:06 am
by fedup
Tried analgous entry again; third time, it worked! Printer now works OK. Thanks for help.