Page 1 of 1

Unable to Install on Suse 10.2 - error message

Posted: Fri Nov 13, 2009 11:28 am
by Toastrack
Trying to install the trial version of Turboprint on my Suse 10.2 machine, I get as far as the Yast window, then an Error message followed by "Another process is accessing the package database".

I have nothing else commanded to be running. What sort of background programs might be running to cause this problem? Or is there something else wrong ?

Monday: I have had several abortive attempts to install, using three different downloads and alternative methods of running the rpm.

Just clicking on the rpm causes execution ok, but the installation fails with a list of error messages and a number if .tif files it says cannot be found.

Please, can someone come to my aid ?? So far turboprint is not living up to the recommendations !!

Posted: Mon Nov 16, 2009 3:32 pm
by zedonet

I don't know why the RPM installation of TurboPrint doesn't work on your system - however the error message "Another process is accessing the package database" has nothing to do with TurboPrint. It means that another program (an RPM package installer or a system update tool) has currently locked the RPM database, so Yast cannot install TurboPrint (or any other RPM package).

A reboot might help. Otherwise I recommend to install the .tgz archive of TurboPrint instead - instructions can be found on the TurboPrint download page.

Posted: Tue Nov 17, 2009 6:54 am
by Toastrack
It won't install the .tgz version either. Tells me various files are missing, and despite downloading the correct software more than once it says it's the 64 bit version. I can't believe more than one mirror would mix up the versions.

Posted: Tue Nov 17, 2009 8:45 am
by zedonet

very strange! Could you please send some additional information:

- is your SuSE 10.2 Linux installation 32bit or 64bit?
- did you download TurboPRint 32bit or 64bit?

What is the exact error message? (please copy the complete output from the TurboPrint Installer window - select the text with the mouse and press CTRL+C to copy text to the clipboard, then paste to the TurboPrint forum editor field. If there are additional messages on the terminal window, please include them as well)

Scenario changed dramatically

Posted: Tue Nov 17, 2009 10:33 am
by Toastrack
Thanks for your reply.
Since yesterday all has changed. I have done nothing to the PC, but today trying clicking on the .rpm download after seeing the jumping icon for a few seconds nothing further happened.

Then, following advice received from another forum, in a terminal I went to root and the Desktop (where the .rpm is) and typed

rpm. -Uvh turboprint-2.12-1.i586.rpm

and lo and behold this time it installed immediately !!

I have set up the printers but now have other problems:-

1. it recognised the HP Deskjet 5440 OK, but then failed to add it to the list. As a trial I chose 555x and a test page printed OK, but I suspect the driver is the wrong one.
2. The epson Stylus Photo on a network printserver it also recognises and seems to set up OK, but nothing prints. I have checked that the printer is started in CUPS. I get the message
/usr/lib/cups/backend.lpd failed.

3. The Epson Stylus D78 on my WinXP box, the same result happens.

Both the above do still print OK via the still-present original CUPS setup.

4. The Canon Pixma IP4500 on the WinXP box also will not print, and the message shown is
printing 23% complete
but no more movement and no printing.

I wonder if I need to delete the earlier CUPS printer items ? Although I commanded the Test Page printings from the turboprint-related CUPS commands.

STOP PRESS. I have now got three of the printers to work fine. The Printer Name was critical.

I am left with the Epson Stylus Photo on a printserver on the network, which still refuses to print. (It prints OK via the same network from the WinXP box, so i know the printer and server are operating.)
I have tried several combinations of printer name and both kinds of network connection offered by turboprint, but I can get nothing to print. On testing the server connection it says the connection is successful, but adds the message:
Server reports Queue Status='(LPD Server:)'

Looks like I am left with this one thing I can't solve.

Posted: Fri Nov 20, 2009 10:55 am
by Toastrack
I still cannot get the Epson Stylus Photo printer to print. I get the message "Control file sent successfully", but nothing prints.

Also, despite having checked this to happen, turboprint does not start at boot-up. I have to start it manually in root. How do i correect this please ?