No connection to turboprint daemon

Questions on Installation
Post Reply
pjj
Posts: 4
Joined: Sat Dec 12, 2009 5:48 pm

No connection to turboprint daemon

Post by pjj » Sat Dec 12, 2009 5:59 pm

I am installing Turboprint 2.12 on Kubuntu 9.10 with a HP PhotoSmart1215 printer on a USB connection.

Cannot find printer under 'standard' or USB but managed to get the correct (I think) UIR anyway. Printer applet sets up 'new printer'.
URI: usb://HP/HP_PhotoSmart1215 (shown in System Settings)

Alternative URI: hp:/usb/photosmart_1215?serial=MY0BS141FPOS (also not working, same error message)

No pages are ever printed. Only sent to printer where they stay waiting for a miracle.

Error message from Turboprint Monitor:

"No connection to turboprint daemon."

How do I fix this, please?

zedonet
Site Admin
Posts: 1751
Joined: Fri Oct 06, 2006 8:02 am

Post by zedonet » Mon Dec 14, 2009 9:09 am

Hello,

1. correct printer URI:

Normally, the port should be listed in TurboPrint Control Center when you add the printer - choose the entry "HP PhotoSmart ... - TP-USB".

If not, you can find the correct URI by entering the following command line in a Terminal window:

sudo /usr/lib/cups/backend/tpu

or for the usb backend

sudo /usr/lib/cups/backend/usb

Then enter the output, e.g. "tpu://HP/PhotoSmart1215" in TurboPrint Control Center - choose "Add" and "Choose port"="other".

2. "no connection to turboüprint daemon"

The daemon is important for TurboPrint Monitor - printing also works without the daemon. It should be started at boot time (you can try to reboot). You can also start it manually with the command

sudo tprintdaemon

(if an error message is reported, please post the message)

pjj
Posts: 4
Joined: Sat Dec 12, 2009 5:48 pm

Post by pjj » Mon Dec 14, 2009 6:58 pm

Zu 1:
I made it work using Cups only. Thank you for the asiistance. I will use it when I switch back to Turboprint.

Zu 2: Error message:

peter@peter-desktop:~$ sudo tprintdaemon
sudo: tprintdaemon: command not found


zedonet wrote:Hello,

1. correct printer URI:

2. "no connection to turboüprint daemon"

sudo tprintdaemon

(if an error message is reported, please post the message)

pjj
Posts: 4
Joined: Sat Dec 12, 2009 5:48 pm

Post by pjj » Tue Dec 15, 2009 5:28 am

[quote="pjj"]Zu 1:
I made it work using Cups only. Thank you for the assistance. I will use it when I switch back to Turboprint.

Zu 2: Error message:

peter@peter-desktop:~$ sudo tprintdaemon
sudo: tprintdaemon: command not found

I spoke hastily!
Now it works also with Turboprint.

The commands under 2: require a 'sudo' in order to work and produce output.

Thanks again.

Post Reply