Printer stopped due to backend errors

Questions on Installation
Post Reply
nikita
Posts: 4
Joined: Mon Nov 09, 2009 7:05 pm

Printer stopped due to backend errors

Post by nikita » Mon Jun 21, 2010 2:35 pm

Hello. I'm using Fedora 13 x86_64
upgraded from fedora 12
turboprint upgraded to current version.
After push button "print" from gimp or test page from tollbox printer status changed to "Stopped"

Code: Select all

[21/Jun/2010:18:23:33 +0400] [Job 80] /usr/lib/cups/filter/pstoturboprint: line 51: kill: (13344) - No such process
D [21/Jun/2010:18:23:33 +0400] [Job 80] /usr/lib/cups/filter/pstoturboprint: line 54: kill: (13346) - No such process
D [21/Jun/2010:18:23:33 +0400] [Job 80] /usr/lib/cups/filter/pstoturboprint: line 71: kill: (13344) - No such process
D [21/Jun/2010:18:23:33 +0400] [Job 80] Backend returned status -11 (crashed)
D [21/Jun/2010:18:23:33 +0400] [Job 80] Printer stopped due to backend errors; please consult the error_log file for details.
D [21/Jun/2010:18:23:33 +0400] [Job 80] End of messages
D [21/Jun/2010:18:23:33 +0400] [Job 80] printer-state=5(stopped)
D [21/Jun/2010:18:23:33 +0400] [Job 80] printer-state-message="TurboPrint: printing page 1, 0% complete..."
D [21/Jun/2010:18:23:33 +0400] [Job 80] printer-state-reasons=paused

nikita
Posts: 4
Joined: Mon Nov 09, 2009 7:05 pm

Post by nikita » Mon Jun 21, 2010 3:13 pm

#rpm -q cups ghostscript
cups-1.4.3-6.fc13.x86_64
ghostscript-8.71-9.fc13.x86_64

Canon Pixma IP 4500

zedonet
Site Admin
Posts: 1770
Joined: Fri Oct 06, 2006 8:02 am

Post by zedonet » Mon Jun 21, 2010 5:06 pm

Hello,

there seems to be a problem with the "backend" - the backend is the Linux component that transfers the print data to the printer.

Please send more information:

- how is the printer connected - USB or network?

- please find out the connection string "URI" - visible in TurboPrint Control Center, column "URI".

- from a terminal window, execute

sudo /usr/lib/cups/backend/tpu
( 64bit system: )
sudo /usr/lib64/cups/backend/tpu

and note the output (printer must be attached and switched on).

- also send the complete /var/log/cups/error_log directly after trying to print

The log file is large, so better send it by email to mail at zedonet dot de (replace "at" by "@" and "dot" by ".").

nikita
Posts: 4
Joined: Mon Nov 09, 2009 7:05 pm

Post by nikita » Mon Jun 21, 2010 6:38 pm

printer is connected through USB
URI: tpu://Canon/iP4500_series

Code: Select all

sudo /usr/lib64/cups/backend/tpu
sudo: /usr/lib64/cups/backend/tpu: command not found
nikita@xxx ~,1# rpm -q cups
cups-1.4.3-6.fc13.x86_64
nikita@xxx ~,1# rpm -q turboprint 
turboprint-2.15-2.x86_64
nikita@xxx ~,0# sudo /usr/lib/cups/backend/tpu
direct tpu://Canon/iP4500_series "Canon iP4500 series" "Canon iP4500 series TP-USB #1" "MFG:Canon;MDL:iP4500 series TurboPrint" ""
nikita@xxx ~,0# cat /etc/redhat-release 
Fedora release 13 (Goddard)
nikita@xxx ~,0# uname -a 
Linux xxx.ultranet.ru 2.6.33.5-124.fc13.x86_64 #1 SMP Fri Jun 11 09:38:12 UTC 2010 x86_64 x86_64 x86_64 GNU/Linux
I sent error_log by email

Post Reply