Page 1 of 1

epson 4800 pro's network setup

Posted: Fri Feb 11, 2011 4:22 pm
by carpman
Hello, i have an epson 4800 stylus pro, i am using Gentoo linux and have installed turbo print via xwing overlay.

I ran tpsetup --update as instructed by ebuild.

I am using the printer own print server via addon network card, i have installed and can print to this printer via cups and guten driver.

When i ran xtpsetup it automatically listed Epson_StylusPro4800, i selected this and it gave

connection - local prnter
device name socket//http:/ (correct IP)

tried printing test page but no go :(

Next i tried tcsetup via console using IPP as connection, with these details in config

Code: Select all



No go with test page form this and cannot see printer as printer option?

Also cups only have the guten driver 4800 printer and no TP printer?

any ideas?


Re: epson 4800 pro's network setup

Posted: Fri Feb 11, 2011 5:00 pm
by zedonet

the printer setup in TurboPrint Control is probably not correct. Please open TurboPrint Control, press "Edit" and set

Printer is: X standard printer
Choose port = Other
Other port = socket://

Then select "OK" and open the "Toolbox" dialog and print a test page.

Re: epson 4800 pro's network setup

Posted: Fri Feb 11, 2011 6:03 pm
by carpman
Hello and thanks for reply.

The only setup or CP i have for TP is xtpsetup ?

I removed the setting from etc/turboprint/turboprint.cfg and started xtpsetup

I click on add printer and the epson 4800 is automatically selected, i click ok.

Know i get edit printer window,

Code: Select all

short name = tp0
config name = Epson_StylusPro_4800
Connection = local printer
device name = socket://

i don't see your options of

Code: Select all

Printer is: 
Choose port = 
Other port = 

There is an option under connection for:

Other (CUPS URI)


Re: epson 4800 pro's network setup

Posted: Mon Feb 14, 2011 10:38 am
by zedonet

the instructions were referring to the GUI setup settings of TurboPrint Control. "Printer is: X standard printer" means that you should select the "standard printer" option in the menu. Select "other" in the popup menu named "Choose port" and type "socket://" in the "Other port" field.

Please make sure that your printer's IP address is reachable within your network, e.g. by typing "ping -c3" in a terminal window. If your packets get lost, the IP address does not match to your IP environment or is not reachable.

Re: epson 4800 pro's network setup

Posted: Tue Feb 15, 2011 11:14 am
by carpman
Hello and thanks for reply. The printer is working fine on the network, can ping and print test page from cups install of printer.

When i run xtpsetup i get following windows:
turbo_print_01.png (57.24 KiB) Viewed 7928 times
turbo_print_02.png (38.58 KiB) Viewed 7928 times
turbo_print_03.png (20.96 KiB) Viewed 7928 times
After 3 i try print test page which does not work, after clicking on 'OK' i see this in console

Code: Select all

hamlet michael # xtpsetup 
lp: Forbidden

Re: epson 4800 pro's network setup

Posted: Wed Feb 16, 2011 6:57 pm
by carpman
Ok got it working, sort of?

I added root and myself to lpd group as this was one error.

I re emerge cups and started with a fresh conf.

I then ran xtpsetup and all went well, printer found and test page printed. TP printer now in cups cp along side gutin print driver.

Now this where the problems starts, can print using the gutin print driver but not the TP driver from apps. Tried printing a test page via cups for TP printer, although it reports the job as printed it never actually get printed?

I check the cup cp printer list and under Status for the TP it says

Idle - "TurboPrint: printing page 1, 99% complete..."

any ideas

Re: epson 4800 pro's network setup

Posted: Thu Feb 17, 2011 9:19 am
by zedonet
I just saw from your screenhots that you are using the old version TurboPrint 1.x which is no longer supported and which is quite tricky to install on current Linux distributions (sorry that I didn't recognize this earlier).

I suggest to download and install TurboPrint 2.18 from -> link "Download" - then you can also use my previous printer setup instructions.