printer off or not connected

Linux distribution specific questions
donaldt
Posts: 16
Joined: Thu Sep 30, 2010 10:16 pm

printer off or not connected

Post by donaldt » Fri Oct 01, 2010 3:09 am

I have a similar problem. My printer works fine in Windows XP. In Ubuntu I am using a blue tooth connection. It has worked great for about 10 months. I recently changed my wireless router and now am unable to print via blue tooth.

The message is "Printer not connected or switched off". Something has changed in Ubuntu 10.4, but the printer still prints from a USB connection out of the XP system.

:( donaldt

zedonet
Site Admin
Posts: 1831
Joined: Fri Oct 06, 2006 8:02 am

Post by zedonet » Fri Oct 01, 2010 7:14 am

Hello,

I think this is a network problem, not a driver problem.

Can you please describe your system:

- which printer do you have
- what kind of wireles router
- what is the "URI" as displayed in TurboPrint Control, column "URI"?

donaldt
Posts: 16
Joined: Thu Sep 30, 2010 10:16 pm

Printer off

Post by donaldt » Fri Oct 01, 2010 8:17 pm

thanks for your prompt response!

My printer is a Canon Pixma mx-860

The wireless is a new Netgear N300 (and by the way the problem started right after it was installed)

URI is: tpu://Canon/pixm860

Hope this helps. The Blue Tooth on my computer is working fine, it sees my wife's I-pad and also itself, my acer portable AS3810T-8640

Hope this helps...

donaldt

zedonet
Site Admin
Posts: 1831
Joined: Fri Oct 06, 2006 8:02 am

Post by zedonet » Mon Oct 04, 2010 10:01 am

Is the printer connected via bluetooth or WLAN? The mentioned Netgear router does not seem to be a Bluetooth but a WLAN router.
In any case, if you have set "tpu://" as URI, the drivers tries to access the printer via USB (directly connected to the computer via USB, not a USB port on the router). Probably you need to connect via network using the IP address of the printer (using the "socket" protocol). Please change the driver connection in TurboPrint Control.

donaldt
Posts: 16
Joined: Thu Sep 30, 2010 10:16 pm

Post by donaldt » Mon Oct 04, 2010 4:12 pm

Thanks once again for your help. You assume my level of knowledge is greater than it actually is.

What is the IP address of the printer and what is the "socket" protocol. Pretend you are talking to a total idiot who knows nothing about these terms, please, and I will try what you suggest.

Donaldt

zedonet
Site Admin
Posts: 1831
Joined: Fri Oct 06, 2006 8:02 am

Post by zedonet » Tue Oct 05, 2010 8:10 am

1. to find the IP address of your router:

Menu "System" -> "Network Tools"
open tab "Netstat" -> press button "Netstat"

In the column "Gateway" there should be one non-zero entry that is the IP address of your router.

You can also open a terminal window and enter
netstat -r -n

2. open TurboPrint Control, press "Edit", choose "other printer"
Then select "Connection" = "Network printer Socket / Jetdirect"
"Server" = <ip address> (something like 192.168.17.1 )
"Port" = 9100

donaldt
Posts: 16
Joined: Thu Sep 30, 2010 10:16 pm

printer off or not connected

Post by donaldt » Tue Oct 05, 2010 2:29 pm

I changed the items you suggested in Turbo Print. It still says it is off or not connected.

I have connected the Pixma MX-860 to the router using the push button method and that is working.

Anything else I can try?

donaldt

zedonet
Site Admin
Posts: 1831
Joined: Fri Oct 06, 2006 8:02 am

Post by zedonet » Tue Oct 05, 2010 3:15 pm

You could try with another network protocol - the "BJNP" protocol:

1. Open a Terminal window and enter

/usr/lib/cups/backend/bjnp
(/usr/lib64/cups/backend/bjnp for 64bit Linux)

If the printer is properly connected to the network, something like

Code: Select all

network bjnp://192.168.17.33:8611 "Canon MX860 series" "Canon MX860 series canon" "MFG:Canon;CMD:BJL,BJRaster3,BSCCe,NCCe,PLI;SOJ:TXT01,BJNP2;MDL:MX860
series;CLS:PRINTER;DES:Canon MX860
series;VER:1.060;STA:10;FSI:07;HRI:OTH;MSI:DAT,E3;"
should be reported.

You only need the part "bjnp://192.168.17.33:8611".


2. open TurboPrint Control, press "Edit", choose "other printer"
Then select "Connection" = "other (CUPS URI)"
"URI" = bjnp://192.168.17.33:8611

(enter the actual string that was displayed in the terminal window).

donaldt
Posts: 16
Joined: Thu Sep 30, 2010 10:16 pm

Post by donaldt » Tue Oct 05, 2010 3:46 pm

Tried all that. Changed to cups, entered the reported URI from the terminal read0out and still get the same message. Printer not connected or turned off. weird!!

zedonet
Site Admin
Posts: 1831
Joined: Fri Oct 06, 2006 8:02 am

Post by zedonet » Wed Oct 06, 2010 9:07 am

For the last solution the printer must be connected to the router with a network cable, not via USB.
Additionally, please check in your printer's network settings (on the printer panel) that WLAN is deactivated and LAN is active.

Please check if that is the case, then try the shell command

/usr/lib/cups/backend/bjnp

or if you have a 64bit Linux system:

/usr/lib64/cups/backend/bjnp

If an output is given, your printer is reachable via network and should be reachable with TurboPrint.

Please let me know the output of that command.

donaldt
Posts: 16
Joined: Thu Sep 30, 2010 10:16 pm

Post by donaldt » Thu Oct 07, 2010 10:55 pm

I cannot connect the printer directly to the router as it is upstairs 50' away.

My computer and the Canon printer are side by side downstairs.

I tried the command in the terminal. The response is: network bjnp "unknown" "Canon network printer"

zedonet
Site Admin
Posts: 1831
Joined: Fri Oct 06, 2006 8:02 am

Post by zedonet » Fri Oct 08, 2010 8:18 am

Sorry - in this case the printer is connected to the router by WLAN and the computer is connected by the router by ethernet cable. This is also possible, however the printer must have a proper WLAN connection to the printer.

Please check in your printer's network settings (on the printer panel) that WLAN is ACTIVE and LAN is NOT active. The printer should display an IP address in the display. You can also print a network status sheet on the printer that contains the IP address.

The URI is then bjnp://ip-address

donaldt
Posts: 16
Joined: Thu Sep 30, 2010 10:16 pm

Canon Pixma MX860

Post by donaldt » Thu Oct 14, 2010 6:02 pm

Sorry!

I've been traveling the past week. I tried your latest suggestion. No change, still the same message...printer not connected or turned off.

donaldt

donaldt
Posts: 16
Joined: Thu Sep 30, 2010 10:16 pm

Post by donaldt » Thu Oct 14, 2010 11:29 pm

Further to your last suggested fix. I have confirmed that Wireless LAN is enabled and active. Wired is disabled and inactive.

I printed out a page that shows:

MAC 00:1E:8F:71:E9:CE
IPv4
IP address: 192.168.1.3
default Gateway: 192.168.1.1
Subnet mask: 255.255.255.0

connection mode: Infrastructure
Encryption: AES
WEP key length: Inactive
Authentication: WPA2-PSK

All of the above from the print-out at the printer. Does this help??

zedonet
Site Admin
Posts: 1831
Joined: Fri Oct 06, 2006 8:02 am

Post by zedonet » Fri Oct 15, 2010 8:52 am

Please try the following:

Open TurboPrint Control, press "Edit", choose "other printer"
Then select "Connection" = "other (CUPS URI)"
"URI" = bjnp://192.168.1.3

Then try to print.
Also open TurboPrint Monitor and check if printer information (status & ink levels) is shown.

Post Reply