Epson SX525WD and auto duplex

Post Reply
robin55
Posts: 8
Joined: Fri Oct 19, 2007 7:30 pm

Epson SX525WD and auto duplex

Post by robin55 » Tue Mar 13, 2012 9:39 pm

Basically doesn't work! 99 times out of 100 the first side prints fine, the sheet is sucked back into the duplexer about 30mm, then the printer stops with a "jam". Except when the printer's opened up it's clear it isn't really jammed at all. No evidence of any mis-alignment, creasing, corner damage or folding, etc.

Print a single, 2-sided, page with next to nothing on each side and it sometimes works, but with a real document it always fails.

For a long time I thought this was due to the combination of a cheap printer and, maybe, the paper stock I was using, but I've recently installed the Epson drivers onto a Windows machine and that works just fine time after time. Page after page of double sided printing without hesitation. Follow that immediately with the same document via Printfab/Windows and presto! the first page jams without fail.

The behaviour seems to change depending on whether "borderless" is selected or not, though results are inconclusive and I've not been able to reproduce them enough for any clear pattern to emerge. All I can say is that sometimes the paper is drawn back further, only to crunch up at the entrance to the rear duplexer. A genuine jam, but why it happens is a mystery. The Epson/Windows driver disallows "A4 borderless", so my efforts have concentrated on A4 (with border) throughout.

Setup is:
Epson SX525WD connected to the LAN via wired ethernet/switch. (NO USB connection).
Drivers: Turboprint 2.24-1 (Linux), Epson Color printing System V.6.74 and PrintFab Studio 0.89beta (Windows).
Document source: Various, but most commonly PDF/Acrobat, stand-alone or browser-embedded.

If it's relevant, note that the Linux Turboprint system has been updated several times from earlier versions using "yum updatelocal <new>.rpm, which clearly doesn't update the (cups) .ppd and other files, such as /etc/turboprint/*.cfg (thank goodness!).

Also, a minor point, it seems tpdaemon is mis-described in /etc/init.d/tpdaemon as a USB handler - it's needed for ether connection also, as Turboprint Monitor well knows!

zedonet
Site Admin
Posts: 1887
Joined: Fri Oct 06, 2006 8:02 am

Re: Epson SX525WD and auto duplex

Post by zedonet » Wed Mar 14, 2012 8:49 am

Hello,

it seems that the problem occurs if the page is filled up to the lower margin. I'll send you an experimental driver file by email that should fix the problem.

robin55
Posts: 8
Joined: Fri Oct 19, 2007 7:30 pm

Re: Epson SX525WD and auto duplex

Post by robin55 » Wed Mar 14, 2012 11:20 am

Many thanks for the prompt response. Email received, I'll give it a try.

Post Reply