cupsys going, going, GONE from Debian

Post Reply
dibl
Posts: 3
Joined: Mon Oct 11, 2010 6:34 pm

cupsys going, going, GONE from Debian

Post by dibl » Mon Oct 11, 2010 6:40 pm

It appears that the TurboPrint driver installer has a hardwired dependency on the cupsys package (I'm using ver. 2.12). While there is still a "transitional" cupsys package in Debian Lenny, it is gone from Sid/Squeeze, and is superseded by the new cups package.

A poor-quality workaround, for people like me running a Sid system, is to install the transitional cupsys package from the Lenny repo, and then to install the TurboPrint driver. But this leaves an outdated CUPS system in place on the system, and will cause other issues, I'm sure.

A better solution would be to update the driver installer to look for the cups package, as well as the cupsys package.

Thanks!

zedonet
Site Admin
Posts: 1792
Joined: Fri Oct 06, 2006 8:02 am

Post by zedonet » Tue Oct 12, 2010 8:34 am

Hello,

this has already been fixed in TurboPrint 2.16

Code: Select all

Depends: libc6, libglib2.0-0, libx11-6, libxext6, libxi6, libgtk2.0-0, cupsys | cups
If you want to install an older version of TurboPrint, you can also use the .tgz download available on ftp://ftp.zedonet.com/tp2

dibl
Posts: 3
Joined: Mon Oct 11, 2010 6:34 pm

Post by dibl » Tue Oct 12, 2010 8:46 pm

Aha -- I searched but couldn't find anything about that.

OK, thank you very much for a speedy response -- time to upgrade!

Post Reply