Canon MG7550 paper type problem

Questions on certain printers and applications
Post Reply
spinor
Posts: 4
Joined: Wed Jul 22, 2015 1:55 pm

Canon MG7550 paper type problem

Post by spinor » Wed Jul 22, 2015 2:16 pm

Hi

I'm currently evaluating Turboprint 2.36-1 and it all looks pretty good so far, except for one problem. I put paper into my Canon MG7550, set the media type to "Plus Glossy II" on the printer's control panel, set "Canon PhotoPlus II PP201" in TC's setup (or GIMP plugin), but when I hit print the printer beeps and says "The size or type of paper in cassette 2 is different from the print settings: A4 Pro platinum, cassette 2". The only way I can then print is by pressing "Print with paper in cass. settings". It works OK when both driver and printer are set to plain paper, but not Plus II 201. What am I doing wrong?

Cheers

Jonathan

zedonet
Site Admin
Posts: 1777
Joined: Fri Oct 06, 2006 8:02 am

Re: Canon MG7550 paper type problem

Post by zedonet » Mon Jul 27, 2015 2:36 pm

Hello,

I could verify this problem - TurboPrint sends the control code for "Pro Platinum Paper" to the printer instead of "Photo Paper Plus Glossy II" (the correct color profile is still active).

A workaround is to set the printer to "Canon Pro Platinum" paper - even if you put "Plus Glossy II" paper into the cassette.
We will correct the problem in the next release. I can also send you a new driver if you are interested.

spinor
Posts: 4
Joined: Wed Jul 22, 2015 1:55 pm

Re: Canon MG7550 paper type problem

Post by spinor » Mon Jul 27, 2015 4:25 pm

Thanks for your reply and workaround. I would certainly be interested in the updated driver. If I buy TC soon would the fixed version definitely become available within the 6 months free-update period?

There's also one other minor problem I've noticed: tpdaemon dies on a regular basis and the print monitor says "ERROR - no connection to turboprint daemon". I then have to restart tpdaemon from the command line with "service tpdaemon restart", which responds:
tprintdaemon: no process found
TP-Daemon Version 2.36-1
Debug Level set to 0
TurboPrint daemon restarted

confirming that the process had previously stopped. It's then OK for a while. I have also tried starting tpdaemon directly from the shell in order to check for any messages sent to STDERR or STDOUT, but it doesn't report any reason for the crashes there or in the log files. (I'm running Fedora 22 on an Acer Aspire 5750 laptop.)

Post Reply