Canon Pixma 9120 paper size problem

Questions on certain printers and applications
Post Reply
Lindy
Posts: 2
Joined: Fri Sep 20, 2019 2:50 am

Canon Pixma 9120 paper size problem

Post by Lindy » Fri Sep 20, 2019 3:55 am

I'm running TurboPrint 2.48.2 in SuSE 15.1, and the problem I'm having is paper selection. I have both the printer and TurboPrint set to use US letter size, but when I print anything the Settings in the info tab of the print monitor show ==> Page size=A4 . The document will print if I tell the printer to print anyway. :?:

zedonet
Site Admin
Posts: 1777
Joined: Fri Oct 06, 2006 8:02 am

Re: Canon Pixma 9120 paper size problem

Post by zedonet » Fri Sep 20, 2019 7:53 am

Hello,

you can set the default page size in TurboPrint Control -> dialog "Configure".

Some apps use the printer driver system defaults instead of the user defaults, you can change the system defaults by starting TurboPrint Control from a terminal window with the command

sudo turboprint

(your login password will be requested) and then open the "Configure" dialog.

Some apps have their own defaults, e.g. in Firefox you need may need to change the default page size within the Firefox settings.

Lindy
Posts: 2
Joined: Fri Sep 20, 2019 2:50 am

Re: Canon Pixma 9120 paper size problem

Post by Lindy » Fri Sep 20, 2019 2:27 pm

Well yes, I did try to set the default page size in the configure dialogue. I also ran TurboPrint as root from the cli which turned up...

Code: Select all

EvilContraption:/home/lindy # export DISPLAY=:0
EvilContraption:/home/lindy # turboprint
No protocol specified
No protocol specified

(turboprint:3191): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

(turboprint:3191): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

(turboprint:3191): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

(turboprint:3191): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

(turboprint:3191): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

(turboprint:3191): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

(turboprint:3191): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

(turboprint:3191): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

(turboprint:3191): Gtk-WARNING **: Failed to set text from markup due to error parsing markup: Error on line 1: Entity did not end with a semicolon; most likely you used an ampersand character without intending to start an entity - escape ampersand as &

(turboprint:3191): Gtk-CRITICAL **: IA__gtk_notebook_set_tab_label: assertion 'GTK_IS_WIDGET (child)' failed

(turboprint:3191): Gtk-CRITICAL **: IA__gtk_widget_child_notify: assertion 'GTK_IS_WIDGET (widget)' failed

** (turboprint:3191): WARNING **: Widget not found: label_nocolorspaces
label nocolorspaces not found
No protocol specified
No protocol specified
No protocol specified
original options:  -o media='Letter' -o Resolution='600x600dpi' -o ColorModel='RGB' -o zedoDithering='ErrorDiffusion' -o MediaType='Plainpaper_4' -o InputSlot='TopFeed' -o zedoUserColor=0 -o zedoMirror=0 -o zedoDuplexAdjust=0 -o zedoBrightness=0 -o zedoContrast=0 -o zedoGamut=0 -o zedoIntensity=0 -o zedoShadows=0 -o zedoAdjustY=0 -o zedoAdjustC=0 -o zedoAdjustM=0 -o zedoAdjustK=0 -o zedoColorspace='0' -o zedoCMYKspace='0' -o zedoIntent='perception_0' -o zedoInklimitY=-50 -o zedoInklimitC=0 -o zedoInklimitM=0 -o zedoInklimitK=0 -o zedoRefLight=65 -o zedoGreyToneA=0 -o zedoGreyToneB=0 -o zedoUCR=0 -o zedoTAC=10 -o zedoBrightC=0 -o zedoBrightM=0 -o zedoPreview='1' -o zedoBorderlessExpand='2' -o zedoDuplexadvanced='auto' -o zedoSettingA=1 -o zedoSettingB=0 -o zedoSettingC=0 -o zedoSettingD=1 -o copies=1 -o sides='one-sided' -o number-up=1 -o columns=1 -r prettyprint -o cpi=10 -o lpi=6 -r PageSize -r Duplex -r orientation-requested
new options:  -o media='Letter' -o Resolution='600x600dpi' -o ColorModel='RGB' -o zedoDithering='ErrorDiffusion' -o MediaType='Plainpaper_4' -o InputSlot='TopFeed' -o zedoUserColor=0 -o zedoMirror=0 -o zedoDuplexAdjust=0 -o zedoBrightness=0 -o zedoContrast=0 -o zedoGamut=0 -o zedoIntensity=0 -o zedoShadows=0 -o zedoAdjustY=0 -o zedoAdjustC=0 -o zedoAdjustM=0 -o zedoAdjustK=0 -o zedoColorspace='0' -o zedoCMYKspace='0' -o zedoIntent='perception_0' -o zedoInklimitY=-50 -o zedoInklimitC=0 -o zedoInklimitM=0 -o zedoInklimitK=0 -o zedoRefLight=65 -o zedoGreyToneA=0 -o zedoGreyToneB=0 -o zedoUCR=0 -o zedoTAC=10 -o zedoBrightC=0 -o zedoBrightM=0 -o zedoPreview='1' -o zedoBorderlessExpand='2' -o zedoDuplexadvanced='auto' -o zedoSettingA=1 -o zedoSettingB=0 -o zedoSettingC=0 -o zedoSettingD=1 -o copies=1 -o sides='one-sided' -o number-up=1 -o columns=1 -r prettyprint -o cpi=10 -o lpi=6 -r PageSize -r Duplex -r orientation-requested


In the printer toolbox if I select to print a letter sized test page the setting in the info tab of the monitor will show==> Page size=US-Letter, and the page will print just fine, and it will also print .odt files without a hitch. But any other file type, .txt, .pdf, or image file, and the settings will revert to A4 , and I'll get the dreaded paper mismatch error. :/

kineotech
Posts: 1
Joined: Wed Oct 02, 2019 2:31 pm

Re: Canon Pixma 9120 paper size problem

Post by kineotech » Wed Oct 02, 2019 2:40 pm

I have this exact same problem running the same version of TurboPrint on Ubuntu 18.04 and two printers: Canon TS9120 and Brother HL2270DW. Both printers will end up printing using the A4 page size even though my default is set to US-Letter. And with the default in TurboPrint Config set to US-Letter, I check the printer properties before clicking the Print button, it is set to A4. And if I manually set that to US-Letter right before clicking Print the TurboConfig status reports it is printing in A4. Very frustrating! The connection for both printers is "Network printer Socket/Jetdirect" so I don't think any CUPS configuration should be involved. Either way, CUPS is also configured with US-Letter as default.

zedonet
Site Admin
Posts: 1777
Joined: Fri Oct 06, 2006 8:02 am

Re: Canon Pixma 9120 paper size problem

Post by zedonet » Fri Oct 18, 2019 1:33 pm

Sorry for the delay.

TurboPrint actually sets A4 as the default paper size during installation. However, it should be no problem to change this with TurboPrint Control (as described in my last post).

Can you please open a terminal window and execute the following command:

lpoptions -p <printername>

where <printername> is the CUPS printer queue name as shown in TurboPrint Control, column "Name".
If you see something like "media=A4" or "PageSize=A4"

then enter

lpoptions -r media

or

lpoptions -r PageSize

to remove this wrong default setting.

If that doesn't help, please post

- from which application(s) did you print?
- the output of "lpoptions -p <printername>"
- the log file /var/log/turboprint/print.log (section for last print job starting from "###### New print job" is sufficient).

Post Reply