Upgraded version 2, can not print. Unknown device: cups

Questions on Installation
Post Reply
Stewart
Posts: 14
Joined: Fri Dec 26, 2008 4:26 pm

Upgraded version 2, can not print. Unknown device: cups

Post by Stewart » Fri Dec 26, 2008 5:05 pm

Just upgraded from 1.94 and have had several things not work smoothly:

1. After rebooting, tpdaemon did not start, so I added it manually to /etc/rc.d/rc.M I'll assume my distribution format was not automatically detected.
2. Checking Preview Jobs never shows anything in turboprint monitor.
3. Ink consumption is still a blank index card, even though I tried checking the Print Simulation box several times.
4. sending a print job from Gimp does not bring up the featured plug-in module.
and most importantly:
5. Nothing will print.

# cat /var/log/turboprint/install.log
#######################################################
install-post started Thu Dec 25 10:02:38 PST 2008
**************************************************************************
TurboPrint Studio 2.06-1 (14-NOV-2008) (c) ZEDOnet GmbH
*** unregistered ***
**************************************************************************
TP_RPM=0
TP_CUPS=1
TP_USER=root
TP_DISPLAY=:0.0
TPDAEMON_USER=lp
TPDAEMON_GROUP=lp
Installing color space ISO Coated v2 (ECI) successful
Restarting tprintdaemon as USER=root DISPLAY=:0.0
install-post finished Thu Dec 25 10:02:55 PST 2008
#######################################################

For the parallel port printer, I see the following:

TPMonitor says the printer is Not connected or off.
After I modprobe parport_pc (and I wonder why it isn't doing this automatically anymore) then I can get a result from the cups backend:
# lpinfo -v
network socket
direct tpu://Canon/iP6220D
direct usb://Canon/iP6220D
network http
network ipp
network lpd
direct parallel:/dev/lp0
direct scsi

# /usr/lib/cups/backend/parallel
direct parallel:/dev/lp0 "Unknown" "LPT #1"

But TPMonitor still says Not connected.

# cat /etc/printcap
# This file was automatically generated by cupsd(8) from the
# /etc/cups/printers.conf file. All changes to this file
# will be lost.
tp0|HP_DeskJet1220C_Draft:rm=Roxy:rp=tp0:
tp1|Canon_PIXMA_iP6220D_Draft:rm=Roxy:rp=tp1:
tp2|Canon_PIXMA_iP6220D_Medium_Letter:rm=Roxy:rp=tp2:
tp3|Canon_PIXMA_iP6220D_Medium_Envelope:rm=Roxy:rp=tp3:
tp4|HP_DeskJet1220C_Medium_Letter:rm=Roxy:rp=tp4:
tp5|Canon_PIXMA_iP6220D_Photo_4x6:rm=Roxy:rp=tp5:

For BOTH printers, when I send a print job, or test page, it shows up in jobs, and Idle changes to Printing, but nothing comes out, and sometimes I see Last Job failed 'Premature end of print data'
and sometimes no error at all.

If I try to send a test page from cups directly, when I stop the printer from accepting jobs, I find the job in /var/spool/cups to be in Postscript format, which of course won't print on these 2 printers without turboprint translating.

Here are the errors I can find, I am just pasting one print job, but they all are similar:
# less /var/log/turboprint/print.log
NEW PRINT JOB Thu Dec 25 14:32:25 PST 2008 (pstoturboprint 2.05-1)
job-id 117
user root
title TurboPrint Testpage
copies 1
options media=Letter sides=two-sided-long-edge finishings=3 job-uuid=urn:uuid:f6f2ba2a-a1a8-3258-6cad-c0c291fa8899
file
queue tp1
test directory access:
drwxr-xr-x 2 root root 10240 Dec 25 10:02 /usr/share/turboprint/printers
linux-gate.so.1 => (0xffffe000)
libm.so.6 => /lib/libm.so.6 (0xa7ed2000)
libc.so.6 => /lib/libc.so.6 (0xa7da8000)
/lib/ld-linux.so.2 (0xa7f0d000)
/usr/bin/tpprint -v2 -l/var/log/turboprint/print.log --ppdfile=/etc/cups/ppd/tp1.ppd --psfeatures /tmp/pstoturboprint3109.chunk /tmp/pstoturboprint3109.var
Searching PPD file and postscript header for options...
check_flag_file: opening /var/turboprint/root/prv/tp1
check_flag_file: opening /var/turboprint/root/sml/tp1
----------- Start of var file -----------
ZEDOPARM="$ZEDOPARM zedoPageRegion=Letter"
ZEDOPARM="$ZEDOPARM zedoMediaType=Plainpaper_6"
ZEDOPARM="$ZEDOPARM zedoInputSlot=AutomaticFeed"
ZEDOPARM="$ZEDOPARM zedoColorModel=RGB"
ZEDOPARM="$ZEDOPARM zedoDithering=ErrorDiffusion"
ZEDOPARM="$ZEDOPARM zedoMirror=0"
ZEDOPARM="$ZEDOPARM zedoDuplexAdjust=0"
ZEDOPARM="$ZEDOPARM zedoColorspace=0"
ZEDOPARM="$ZEDOPARM zedoCMYKspace=0"
ZEDOPARM="$ZEDOPARM zedoIntent=perception-inksave_1"
ZEDOPARM="$ZEDOPARM zedoIntensity=0"
ZEDOPARM="$ZEDOPARM zedoBrightness=0"
ZEDOPARM="$ZEDOPARM zedoContrast=0"
ZEDOPARM="$ZEDOPARM zedoColorY=0"
ZEDOPARM="$ZEDOPARM zedoColorM=0"
ZEDOPARM="$ZEDOPARM zedoColorC=0"
ZEDOPARM="$ZEDOPARM zedoColorK=0"
ZEDOPARM="$ZEDOPARM zedoInklimitY=0"
ZEDOPARM="$ZEDOPARM zedoInklimitM=0"
ZEDOPARM="$ZEDOPARM zedoInklimitC=0"
ZEDOPARM="$ZEDOPARM zedoInklimitK=0"
ZEDOPARM="$ZEDOPARM zedoRefLight=65"
ZEDOPARM="$ZEDOPARM zedoGreyToneA=0"
ZEDOPARM="$ZEDOPARM zedoGreyToneB=0"
ZEDOPARM="$ZEDOPARM zedoGamut=0"
ZEDOPARM="$ZEDOPARM zedoUCR=0"
ZEDOPARM="$ZEDOPARM zedoTAC=0"
ZEDOPARM="$ZEDOPARM zedoBrightC=0"
ZEDOPARM="$ZEDOPARM zedoBrightM=0"
ZEDOPARM="$ZEDOPARM zedoDuplexadvanced=manual"
ZEDOPARM="$ZEDOPARM zedoBorderlessExpand=2"
ZEDOPARM="$ZEDOPARM zedoResolution=300x300dpi"
ZEDOPARM="$ZEDOPARM zedoDuplex=None"
ZEDOPARM="$ZEDOPARM zedoPrinterDriver=Canon_PIXMA_iP6220D"
GSPPDFOUND=1
GSCOLORMODE=2
GSXDPI=300
GSYDPI=300
GSWIDTH=2550
GSHEIGHT=3300
TPWIDTH=8500
TPHEIGHT=11000
TPXOFFSET=0
TPYOFFSET=0
DUPLEX=0
PREVIEW=0
NOPRINT=0
BORDERLESS=0
PVXDPI=93
PVYDPI=93
PVWIDTH=790
PVHEIGHT=1023
----------- End of var file -----------
tpstdin --parsedsc result=0
GSRESULT=GPL Ghostscript 8.60 (2007-08-01) GSVERSION=GPL GSMAJOR=8 GSMINOR=60 GSCUPSDEVICE=1
GSCOMMANDLINE=gs -sDEVICE=cups -r300x300 -dNOMEDIAATTRS -dSAFER -dNOPAUSE -dBATCH
TPCOMMANDLINE=/usr/bin/tpprint --cups -v2 -l/var/log/turboprint/print.log --ppdfile=/etc/cups/ppd/tp1.ppd --psheader=/etc/cups/ppd/tp1.ppd ---zedoPageRegion=Letter ---zedoMediaType=Plainpaper_6 ---zedoInputSlot=AutomaticFeed ---zedoColorModel=RGB ---zedoDithering=ErrorDiffusion ---zedoMirror=0 ---zedoDuplexAdjust=0 ---zedoColorspace=0 ---zedoCMYKspace=0 ---zedoIntent=perception-inksave_1 ---zedoIntensity=0 ---zedoBrightness=0 ---zedoContrast=0 ---zedoColorY=0 ---zedoColorM=0
---zedoColorC=0 ---zedoColorK=0 ---zedoInklimitY=0 ---zedoInklimitM=0 ---zedoInklimitC=0 ---zedoInklimitK=0 ---zedoRefLight=65 ---zedoGreyToneA=0 ---zedoGreyToneB=0 ---zedoGamut=0 ---zedoUCR=0 ---zedoTAC=0 ---zedoBrightC=0 ---zedoBrightM=0
---zedoDuplexadvanced=manual ---zedoBorderlessExpand=2 ---zedoResolution=300x300dpi ---zedoDuplex=None ---zedoPrinterDriver=Canon_PIXMA_iP6220D --jobid=117 --username=root '--title=TurboPrint Testpage'
COMPLETEPIPE=/usr/share/turboprint/lib/tpstdin --paste /tmp/pstoturboprint3109.chunk | gs -sDEVICE=cups -r300x300 -dNOMEDIAATTRS -dSAFER -dNOPAUSE -dBATCH -sOutputFile=/tmp/pstoturboprint3109.fifo - >> /var/log/turboprint/print.log
PREVIEWPIPE=
----------- Start of print job -----------
starting child process
tpprint 2.06-1 (14-NOV-2008) - TurboPrint printer driver
Copyright (C)ZEDOnet GmbH, Irsee, Germany. All rights reserved.
Searching PPD file and postscript header for options...
interpret_ps: no output file specified
GPL Ghostscript 8.60 (2007-08-01)
Copyright (C) 2007 Artifex Software, Inc. All rights reserved.
This software comes with NO WARRANTY: see the file PUBLIC for details.
Unknown device: cups
Unrecoverable error: undefined in .uninstallpagedevice
Operand stack:
defaultdevice
pixmap_class::open: can't read magic header
print_page: end of input file
child process terminated
------------ End of print job - result = 246 ------------
job cancelling procedure - TPPID=3126 GSPID=3128 PVPID=
------------ END of tpprint filter ------------

System is Linux-2.6.24.7 cups-1.3.6

Requesting instructions.
Stewart

zedonet
Site Admin
Posts: 1781
Joined: Fri Oct 06, 2006 8:02 am

Post by zedonet » Mon Dec 29, 2008 10:16 am

Hello Stewart,

it looks like there is a cups problem on your system. There is a known problem with a recent cups 1.3.6 update. This problem is fixed with the latest cups update to 1.3.9. Please check if any CUPS updates are available on your system.

zedonet
Site Admin
Posts: 1781
Joined: Fri Oct 06, 2006 8:02 am

Post by zedonet » Mon Dec 29, 2008 10:45 am

...after looking at the log file once again:

The problem is caused by ghostscript version 8.60 that doesn't have the "cups raster" output device.

This can be solved by either upgrading ghostscript to at least version 8.61 or by editing /usr/lib/cups/filter/pstoturboprint:

change the line

if [ $GSMAJOR -ge 8 -a $GSMINOR -ge 60 ] ; then

to

if [ $GSMAJOR -ge 8 -a $GSMINOR -ge 61 ] ; then

Stewart
Posts: 14
Joined: Fri Dec 26, 2008 4:26 pm

Post by Stewart » Mon Dec 29, 2008 5:25 pm

I upgraded to cups-1.3.9 and that had no effect.
I upgraded to ghostscipt-8.63, and that fixed the printing problem.

I still notice these bugs:
1. direct parallel:/dev/lp0 continuously flashes "Printer not connected or switched off" EVEN During and After printing the test page successfully.

kernel reports in /var/log/messages:
Dec 29 08:44:01 Roxy kernel: parport_pc 00:08: reported by Plug and Play ACPI
Dec 29 08:44:01 Roxy kernel: parport0: PC-style at 0x378, irq 7 [PCSPP,TRISTATE,
EPP]
Dec 29 08:44:01 Roxy kernel: parport0: Printer, HEWLETT-PACKARD DESKJET 1220C
Dec 29 08:44:01 Roxy kernel: lp0: using parport0 (interrupt-driven).

Any ideas I could try? to get more information for you?

2. I see an error printing to the usb Canon,
ERROR:
inifile::write: could not open output file
/var/turboprint/ink/tp1.ink
ERROR:
inifile::write: could not open output file
/var/turboprint/sandreas/tp1.ink

# ls /var/turboprint/sandreas/tp[012]*
-rw-r--r-- 1 root root 32 Dec 25 11:56 /var/turboprint/sandreas/tp1.ink
-rw-r--r-- 1 root root 32 Dec 26 09:29 /var/turboprint/sandreas/tp2.ink
-rw-rw-rw- 1 lp lp 164 Dec 26 09:55 /var/turboprint/sandreas/tp2.job
-rw-rw-rw- 1 lp lp 134 Dec 29 08:45 /var/turboprint/sandreas/tp0.job
-rw-rw-rw- 1 lp lp 137 Dec 29 08:45 /var/turboprint/sandreas/tp0.ink
-rw-rw-rw- 1 lp lp 166 Dec 29 08:51 /var/turboprint/sandreas/tp1.job

I think root made the 4 files first (2 in each directory mentioned), when I was installing and configuring the first time, and now it is unwritable. I change the owner to lp, and that fixes that problem.
That looks like a bug! If root checks out the print monitor during installation, then it won't work for users.

3. Have you tried this:
> gv /usr/share/turboprint/dump/testmargins-letter.ps

It has no output, and trying to print it has no output either, but the file loads ok in gimp. Is it a ghostscript bug?

Thank you

Stewart
Posts: 14
Joined: Fri Dec 26, 2008 4:26 pm

Post by Stewart » Mon Dec 29, 2008 6:23 pm

The last of the issues I initially reported, the plugin for gimp, I have solved. It was not installed, and install.log does not mention it. So I'll shrug and copy gpturboprint manually. :?

I am very excited about print preview and ink level counting. :D

Here is another 2 questions:
4. How can I adjust the vertical offset or default for one printer without creating custom page sizes? The top line is consistantly chopped off, and there is extra white space at the bottom of the HP Deskjet 1220C.

5. Have you noticed what happens to the expiration date after re-entering
# turboprint

Post Reply