Epson P400, Gloss Optimizer, Luster paper

Questions on certain printers and applications
Post Reply
MRC01
Posts: 13
Joined: Mon Apr 29, 2019 10:57 pm

Epson P400, Gloss Optimizer, Luster paper

Post by MRC01 » Tue Aug 20, 2019 6:48 pm

I'm printing photos using Turboprint (from GIMP on Ubuntu 16) to my Epson P400. Overall I get great results. But when I use Luster paper, it looks like the gloss optimizer is not being used.
In Turboprint, I leave the Gloss Optimizer setting to "automatic". I could force this setting with "Full". But before doing that I want to confirm whether this is intended behavior in Turboprint. In the "automatic" setting, gloss optimizer should be used for both glossy and luster papers. But it's possible that Turboprint only uses it for glossy and not for luster.

MRC01
Posts: 13
Joined: Mon Apr 29, 2019 10:57 pm

Re: Epson P400, Gloss Optimizer, Luster paper

Post by MRC01 » Wed Aug 21, 2019 2:16 pm

I printed with gloss optimizer set to "Full" and the prints are identical as on the "Auto" setting.
So it looks like gloss optimizer is never being used on this Luster paper. To confirm, I'll print yet another one with gloss optimizer set to "Off", for comparison.

MRC01
Posts: 13
Joined: Mon Apr 29, 2019 10:57 pm

Re: Epson P400, Gloss Optimizer, Luster paper

Post by MRC01 » Thu Aug 22, 2019 1:00 am

Results:
As I've been exploring this I found 2 other bugs:

In Turboprint Toolbox Printer Utilities, the "NozzleCheck" button doesn't work. It's supposed to print a page with a nozzle check pattern. But it does nothing. In the same tool, the "Print Testpage" button does work.

The Turboprint Monitor "Info" tab shows data about the current print job. It always says, "Cartridge = GlossOptimizer Auto" regardless of the Gloss Optimizer setting. Even when I select Gloss Optimizer OFF or FULL in TurboPrint's GIMP print plugin, the monitor always shows it as "Auto". Also, prints made in the 3 different modes: Full, Auto and Off are indistinguishable. So the driver is always doing the same thing, ignoring this setting.

zedonet
Site Admin
Posts: 1782
Joined: Fri Oct 06, 2006 8:02 am

Re: Epson P400, Gloss Optimizer, Luster paper

Post by zedonet » Mon Aug 26, 2019 5:01 pm

Hello,

thank you for your problem report.

The problem with the gloss optimizer may be caused by the following restriction in TurboPrint:

When adding a custom color profile, you have to select a gloss optimizer mode (off, auto, on).
Later when printing with this custom color profile, the gloss optimizer mode is fixed to this setting.
Only with the built-in media profiles it is possible to select the gloss optimizer mode for each print.

The reason for this restriction is that the setting "Module" that selects the gloss optimizer mode in the SC-P400 driver is used differently in other printer drivers.
In the SC-P600 driver, "Module" selects the type of black ink (matte black / photo black) and it makes no sense to create the profile with one setting (e.g. photo black) and print with the other setting (e.g. matte black) later.

A workaround may be to add several profiles with different gloss optimizer settings.

I can confirm the problem "Nozzle Check not being printed". We will fix this in the next TurboPrint release.

MRC01
Posts: 13
Joined: Mon Apr 29, 2019 10:57 pm

Re: Epson P400, Gloss Optimizer, Luster paper

Post by MRC01 » Mon Aug 26, 2019 10:06 pm

OK, so from a single custom color profile, I should be able to create several different paper profiles -- one for each different Gloss Optimizer mode I want to use. I'll try that.
Thanks
zedonet wrote:
Mon Aug 26, 2019 5:01 pm
...
A workaround may be to add several profiles with different gloss optimizer settings. ...
After testing, this doesn't work. The gloss optimizer setting is fixed to whatever you selected before printing the custom color data sheet that you mail in to receive the color data file. After you receive the color data file for the sheet you printed, you can create different profiles using this file, and give each different GO settings, but they are all ignored. No matter what you select in the profile, it always prints using the setting you originally selected when printing the custom color data sheet.

zedonet
Site Admin
Posts: 1782
Joined: Fri Oct 06, 2006 8:02 am

Re: Epson P400, Gloss Optimizer, Luster paper

Post by zedonet » Tue Aug 27, 2019 4:08 pm

You are right, the gloss optimizer setting is stored in the profile, after importing the profile the gloss optimizer setting is changed.
I'll email you profiles for the different gloss optimizer settings.

MRC01
Posts: 13
Joined: Mon Apr 29, 2019 10:57 pm

Re: Epson P400, Gloss Optimizer, Luster paper

Post by MRC01 » Tue Aug 27, 2019 4:56 pm

Perfect, received via email. Appreciate the great support - thanks.

Post Reply