Says "Job finished" but did not print

Questions on Installation
Post Reply
Posts: 2
Joined: Sat Jan 07, 2017 10:17 am

Says "Job finished" but did not print

Post by tschiex » Sat Jan 07, 2017 10:48 am

I have been using TurboPrint since version 1. Initially had it on one linux Ubuntu computer.

Now I have an ArchLinux ARM computer (acting as a NAS), a Windows computer and the Ubuntu box. I decided to put the USB printer on the (always up) ARM computer so that I could print both from Windows and Linux w/o having to power up the Ubuntu computer to print from Windows.

Bought the ARM licence for Turboprint2, installed it on the ARM machine. The ARM machine prints well (test page ok, printing a pdf from command line ok) ! Fine. :D

Setup the Windows machine to print on the ARM server using http://armcomputername:631/printers/... The Windows computer prints well (printed a PDF). Fine. :D

Setup the Ubuntu box (that has CUPS and TurboPrint2 on it) to print on the ARM server using ipp://armcomputername/printers/... Well, looks like it works, connects, ink levels update themselves correctly (and the printer connected on the ARM wakes up when the Ubuntu box connects to gather the ink levels), tried a test page...

From the Ubuntu side, the test page is supposed to print (very quickly) and the job supposed to be finished. On the ARM server side, the printer wakes up, moves a bit but prints nothing (not even a page feed). The Ubuntu and ARM error-logs are not changed when I print the test page (not a single line). :(

The print.log of turboprint hower points to a problem (see end of mail) that seems to indicate gs has a problem with the file syntax ?
However, if I print the same PDF file from the ARM computer directly, everything runs 100% fine...

Or a pipe cannot be created :

Code: Select all

could not open freepipes pipe /var/spool/turboprint/tom/fd 
when /var/spool/turboprint exists:

Code: Select all

drwxrwxr-x  3 root lp   4096 Jan  6 23:25 turboprint
Cannot point out the issue from the log :(

Code: Select all

NEW PRINT JOB sam. janv.  7 11:56:23 CET 2017 (pstoturboprint 2.23-1)
job-id 25
user tom
title G4G8-hart.pdf
copies 1
options noCollate ColorModel=RGB Duplex=None InputSlot=AutoSelect job-uuid=urn:uuid:f934fc1a-3c83-3947-4ec6-64edb75db9d9 MediaType=Plainpaper_4 number-up=1 OutputBin=Front PageSize=A4 Resolution=601x600dpi zedoAdjustC=0 zedoAdjustK=0 zedoAdjustM=0 zedoAdjustY=0 zedoBorderlessE
xpand=2 zedoBrightC=0 zedoBrightM=0 zedoBrightness=0 zedoCMYKspace=0 zedoColorspace=0 zedoContrast=0 zedoDithering=ErrorDiffusion zedoDuplexAdjust=0 zedoDuplexadvanced=auto zedoGamut=0 zedoGreyToneA=0 zedoGreyToneB=0 zedoInklimitC=0 zedoInklimitK=0 zedoInklimitM=0 zedoInklimit
Y=0 zedoIntensity=0 zedoIntent=perception_0 zedoMirror=0 zedoRefLight=65 zedoSettingA=0 zedoSettingB=0 zedoSettingC=0 zedoShadows=0 zedoTAC=0 zedoUCR=0 job-originating-host-name= date-time-at-creation= date-time-at-processing= time-at-creation=1483786580 time-at-pro
file /var/spool/cups/d00025-001
ppdfile /etc/cups/ppd/iP4800series-TurboPrint.ppd
queue iP4800series-TurboPrint
process info: uid=2(daemon) gid=7(lp) groupes=7(lp)
test directory access:
drwxr-xr-x 2 root root 20480  6 janv. 23:25 /usr/share/turboprint/printers => /usr/lib/ (0xb6e4f000) => /usr/lib/ (0xb6dcf000) => /usr/lib/ (0xb6c90000)
        /lib/ (0xb6fad000) => /usr/lib/ (0xb6c64000)
/usr/bin/tpprint -v2 -l/var/log/turboprint/print.log '--username=tom' '--ppdfile=/etc/cups/ppd/iP4800series-TurboPrint.ppd' --psfeatures  '---noCollate' '---ColorModel=RGB' '---Duplex=None' '---InputSlot=AutoSelect' '---job-uuid=urn:uuid:f934fc1a-3c83-3947-4ec6-64edb75db9d9' '
---MediaType=Plainpaper_4' '---number-up=1' '---OutputBin=Front' '---PageSize=A4' '---Resolution=601x600dpi' '---zedoAdjustC=0' '---zedoAdjustK=0' '---zedoAdjustM=0' '---zedoAdjustY=0' '---zedoBorderlessExpand=2' '---zedoBrightC=0' '---zedoBrightM=0' '---zedoBrightness=0' '---
zedoCMYKspace=0' '---zedoColorspace=0' '---zedoContrast=0' '---zedoDithering=ErrorDiffusion' '---zedoDuplexAdjust=0' '---zedoDuplexadvanced=auto' '---zedoGamut=0' '---zedoGreyToneA=0' '---zedoGreyToneB=0' '---zedoInklimitC=0' '---zedoInklimitK=0' '---zedoInklimitM=0' '---zedoI
nklimitY=0' '---zedoIntensity=0' '---zedoIntent=perception_0' '---zedoMirror=0' '---zedoRefLight=65' '---zedoSettingA=0' '---zedoSettingB=0' '---zedoSettingC=0' '---zedoShadows=0' '---zedoTAC=0' '---zedoUCR=0' '---job-originating-host-name=' '---date-time-at-creatio
n=' '---date-time-at-processing=' '---time-at-creation=1483786580' '---time-at-processing=1483786583' /tmp/pstoturboprint16008.chunk /tmp/pstoturboprint16008.var
Searching PPD file and postscript header for options...
set_feature: no value given
page size A4 overwritten by ---media=A4
duplex overwritten by ---Duplex=None
check_flag_file: opening /var/spool/turboprint/tom/prv/iP4800series-TurboPrint
check_flag_file: opening /var/spool/turboprint/tom/sml/iP4800series-TurboPrint
----------- Start of var file -----------
----------- End of var file -----------
tpstdin --parsedsc result=0
GSCOMMANDLINE=gs -sDEVICE=ppmraw -r600x600 -g4960x7015 -dSAFER -dDisableFAPI=true -dNOPAUSE -dBATCH
TPCOMMANDLINE=/usr/bin/tpprint -a0 -e1 -s8268x11693 -p0x0 -v2 -l/var/log/turboprint/print.log  '---noCollate' '---ColorModel=RGB' '---Duplex=None' '---InputSlot=AutoSelect' '---job-uuid=urn:uuid:f934fc1a-3c83-3947-4ec6-64edb75db9d9' '---MediaType=Plainpaper_4' '---number-up=1' '---OutputBin=Front' '---PageSize=A4' '---Resolution=601x600dpi' '---zedoAdjustC=0' '---zedoAdjustK=0' '---zedoAdjustM=0' '---zedoAdjustY=0' '---zedoBorderlessExpand=2' '---zedoBrightC=0' '---zedoBrightM=0' '---zedoBrightness=0' '---zedoCMYKspace=0' '---zedoColorspace=0' '---zedoContrast=0' '---zedoDithering=ErrorDiffusion' '---zedoDuplexAdjust=0' '---zedoDuplexadvanced=auto' '---zedoGamut=0' '---zedoGreyToneA=0' '---zedoGreyToneB=0' '---zedoInklimitC=0' '---zedoInklimitK=0' '---zedoInklimitM=0' '---zedoInklimitY=0' '---zedoIntensity=0' '---zedoIntent=perception_0' '---zedoMirror=0' '---zedoRefLight=65' '---zedoSettingA=0' '---zedoSettingB=0' '---zedoSettingC=0' '---zedoShadows=0' '---zedoTAC=0' '---zedoUCR=0' '---job-originating-host-name=' '---date-time-at-creation=' '---date-time-at-processing=' '---time-at-creation=1483786580' '---time-at-processing=1483786583' '--ppdfile=/etc/cups/ppd/iP4800series-TurboPrint.ppd' --psheader=/tmp/pstoturboprint16008.chunk --jobid=25 '--username=tom' '--title=G4G8-hart.pdf' 
COMPLETEPIPE=/usr/lib/turboprint/tpstdin --paste /var/spool/cups/d00025-001 | gs -sDEVICE=ppmraw -r600x600 -g4960x7015 -dSAFER -dDisableFAPI=true -dNOPAUSE -dBATCH  -sOutputFile=/tmp/pstoturboprint16008.fifo - >> /var/log/turboprint/print.log
----------- Start of print job -----------
starting child process
tpprint 2.37-1 x32 (08-OCT-2015) - TurboPrint printer driver
Copyright (C)ZEDOnet GmbH, Irsee, Germany. All rights reserved.
07-Jan-2017 11:56
PPD file: /etc/cups/ppd/iP4800series-TurboPrint.ppd
header file: /tmp/pstoturboprint16008.chunk
Could not open freepipes pipe /var/spool/turboprint/tom/fd
Searching PPD file and postscript header for options...
GPL Ghostscript 9.20 (2016-09-26)
Copyright (C) 2016 Artifex Software, Inc.  All rights reserved.
This software comes with NO WARRANTY: see the file PUBLIC for details.
Error: /syntaxerror in -file-
Operand stack:

Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   --nostringval--   --nostringval--   false   1   %stopped_push   1999   1   3   %oparray_pop   1998   1   3   %oparray_pop   1982   1   3   %oparray_pop   1868   1   3   %oparray_pop   --nostringval--   %errorexec_pop   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push
Dictionary stack:
   --dict:1209/1684(ro)(G)--   --dict:0/20(G)--   --dict:78/200(L)--
Current allocation mode is local
Last OS error: No such file or directory
set_feature: no value given
page size A4 overwritten by ---media=A4
duplex overwritten by ---Duplex=None
interpret_ps: no output file specified
::set_info_paths: setting preview file to /var/spool/turboprint/tom/zmf/25.zmf
pixmap_class::open: end of file reached
print_page: end of input file
Report at end of pdrivecontrol_class::release_printer
Total memory usage=0
child process terminated
inifile::write: could not open output file
------------ End of print job - result = 246 ------------
job cancelling procedure - TPPID=16030 GSPID=16032 PVPID=
------------ END of tpprint filter ------------
Any idea/suggestion ?

Printer: CANON PIXMA IP4800
ARM ArchLinux with CUPS 2.2.1-1 and turboprint-2.37-1.ARMhf
Ubuntu 16.10 with CUPS 2.2.0-2 and turboprint 2.25 (tried also 2.40 with the same behavior exactly)

Posts: 2
Joined: Sat Jan 07, 2017 10:17 am

Re: Says "Job finished" but did not print

Post by tschiex » Sat Jan 07, 2017 3:28 pm

Well after several modifications, reboots, modifications, printer deletions, creations... it suddenly works. :D

The last thing I did was changing the system.cfg of turboprint to disable gszedo (which is not distributed in the ARM version anyway apparently).

Site Admin
Posts: 1956
Joined: Fri Oct 06, 2006 8:02 am

Re: Says "Job finished" but did not print

Post by zedonet » Mon Jan 09, 2017 8:56 am


thank you for your problem report and also for reporting that the problem is solved.

The log file shows that ghotstscript reports "/syntaxerror in -file-" which means that a syntax in the PDF file to be printed is reported ("G4G8-hart.pdf").

It is correct that the ARM version of TurboPrint doesn't contain the gszedo, the TurboPrint/ZEDOnet specific version of Ghostscript, so always the pre-installed version of ghostscript is used.

Can you print the same PDF file now?

Post Reply