Spooler message: printer not connected

Questions on Installation
Post Reply
luckycat
Posts: 1
Joined: Wed Jun 18, 2014 5:25 pm

Spooler message: printer not connected

Post by luckycat » Wed Jun 18, 2014 5:56 pm

Hi, everybody,

I use ubuntu 14.4 64 bit and have a canon pixma iP4850 printer. In the turboprint printer monitor, I have the message that the printer is not connected, but this absolutely wrong, I have controlled it, it is connected.
What can I do?
Thanks for your help

zedonet
Site Admin
Posts: 1756
Joined: Fri Oct 06, 2006 8:02 am

Re: Spooler message: printer not connected

Post by zedonet » Thu Jun 19, 2014 8:53 am

Hello luckycat,

probably your printer is connected via USB and you are using the standard CUPS USB backend (shown as URI "usb://..." in TurboPrint Control). This USB backend (driver sending data via USB) is blocking the USB port while printing. After printing is finished, the status message should revert to something like "idle".
Instead you should use the USB backend of TurboPrint (URI "tpu://..."). To change the backend, click on the button to edit your printer in TurboPrint Control, then choose the entry with "(TP-USB)" in the list of connected printers. Now TurboPrint should have access to the printer status even while printing.

pteok
Posts: 5
Joined: Sat Jan 03, 2015 4:11 pm

Re: Spooler message: printer not connected

Post by pteok » Sat Jan 03, 2015 4:20 pm

I am getting the same message " Printer not connected" & I don't see "TP-USB" , I don't anything asking for USB. I tried both 32 bit & 64 bit installs. I try to choose "other" for the port but it changes to parallel port. My printer is an Canon ip90.

zedonet
Site Admin
Posts: 1756
Joined: Fri Oct 06, 2006 8:02 am

Re: Spooler message: printer not connected

Post by zedonet » Mon Jan 05, 2015 11:53 am

If only the "parallel port" options are visible when adding the printer in TurboPrint Control, your USB printer is not properly recognized by your computer.

Please check if the printer is listed when you enter the following commands in a "Terminal" window (printer must be attached and switched on):

lsusb

sudo /usr/lib/cups/backend/usb

sudo /usr/lib/cups/backend/tpu

(after entering the commands that start with "sudo", your login password will be requested)

pteok
Posts: 5
Joined: Sat Jan 03, 2015 4:11 pm

Re: Spooler message: printer not connected

Post by pteok » Tue Jan 27, 2015 2:53 pm

The following is from the terminal

DEBUG: Loading USB quirks from "/usr/share/cups/usb".
DEBUG: Loaded 107 quirks.
DEBUG: list_devices
DEBUG: libusb_get_device_list=11
DEBUG2: Printer found with device ID: MFG:Canon;CMD:BJL,BJRaster3,BSCCe;SOJ:TXT01;MDL:iP90;CLS:PRINTER;DES:Canon iP90;VER:1.01;STA:10; Device URI: usb://Canon/iP90?serial=409308
direct usb://Canon/iP90?serial=409308 "Canon iP90" "Canon iP90" "MFG:Canon;CMD:BJL,BJRaster3,BSCCe;SOJ:TXT01;MDL:iP90;CLS:PRINTER;DES:Canon iP90;VER:1.01;STA:10;" ""

The printer will not print, it kicks out continuous blank pages.

zedonet
Site Admin
Posts: 1756
Joined: Fri Oct 06, 2006 8:02 am

Re: Spooler message: printer not connected

Post by zedonet » Thu Jan 29, 2015 2:59 pm

I have no explanation yet. Could you please send some additional information:

1) Did you set up the printer in TurboPrint Control with the URI "usb://Canon/iP90?serial=409308"?
With this setup the printer doesn't print properly but feeds blank pages?

2) Do you get any output when you enter the following command:

sudo /usr/lib/cups/backend/tpu

3) Please also send information about your Linux distribution & version.

pteok
Posts: 5
Joined: Sat Jan 03, 2015 4:11 pm

Re: Spooler message: printer not connected

Post by pteok » Fri Feb 06, 2015 3:16 am

Linux Mint 17 64bit
ver 2.2.16

1) Did you set up the printer in TurboPrint Control with the URI "usb://Canon/iP90?serial=409308"?
With this setup the printer doesn't print properly but feeds blank pages? Nothing happens with this setup

2) Do you get any output when you enter the following command:
sudo /usr/lib/cups/backend/tpu No response from this command

pteok
Posts: 5
Joined: Sat Jan 03, 2015 4:11 pm

Re: Spooler message: printer not connected

Post by pteok » Mon Feb 16, 2015 4:25 pm

Has there been any progress? I would like to use my printer.

zedonet
Site Admin
Posts: 1756
Joined: Fri Oct 06, 2006 8:02 am

Re: Spooler message: printer not connected

Post by zedonet » Mon Feb 16, 2015 4:46 pm

There is no progress - I don't know the reason for the problem yet.

The following information might help:

1. Please post the log file /var/log/turboprint/print.log (the section for the last print job starting from "### new print job" is sufficient)

2. When you add a new printer in TurboPrint Control, which entries do you see in the drop down list "Choose port"?

pteok
Posts: 5
Joined: Sat Jan 03, 2015 4:11 pm

Re: Spooler message: printer not connected

Post by pteok » Sun Feb 22, 2015 3:56 am

I uninstalled all the printer packages & then Reinstalled Turbo Print.
The printer is now working.

Post Reply