PNG, JPEG not printing using Turboprint

Questions on Installation
Post Reply
zellmer
Posts: 3
Joined: Mon Jan 07, 2019 6:40 pm

PNG, JPEG not printing using Turboprint

Post by zellmer » Mon Jan 07, 2019 6:59 pm

I’m using Open SUSE Tumbleweed and Turbo Print Demo Version. I’ve got problem with printing PNG and JPEG flies. There was also problem with text printing but I found this workaround: http://www.turboprint.info/support/view ... 153#p14884 Every time I tray to print a picture this bug occurs
Image
Attachments
Screenshot_20190107_193553.jpg
Screenshot_20190107_193553.jpg (216.14 KiB) Viewed 1080 times

broadstairs
Posts: 73
Joined: Thu Nov 04, 2010 11:50 am

Re: PNG, JPEG not printing using Turboprint

Post by broadstairs » Tue Jan 08, 2019 10:39 am

I just tried printing a jpeg image from gwenview and had no issue at all. I use Tumbleweed also. Does it happen with any image or only one from a particular source? Mine was from a DSLR camera. I also tried a png image which was a screenshot and it also worked OK.

Stuart

zellmer
Posts: 3
Joined: Mon Jan 07, 2019 6:40 pm

Re: PNG, JPEG not printing using Turboprint

Post by zellmer » Tue Jan 08, 2019 8:49 pm

I made some tests. I can't print jpeg and png files using Gwenview and Okular (I tried differnet files from different sources). I have no issue with any jpeg or png files using Gimp and Firefox. How to fix this problem?

broadstairs
Posts: 73
Joined: Thu Nov 04, 2010 11:50 am

Re: PNG, JPEG not printing using Turboprint

Post by broadstairs » Wed Jan 09, 2019 9:24 am

Is your Tumbleweed system fully updated and do you use zypper dup only to update it?

Stuart

zellmer
Posts: 3
Joined: Mon Jan 07, 2019 6:40 pm

Re: PNG, JPEG not printing using Turboprint

Post by zellmer » Wed Jan 09, 2019 6:28 pm

My system is fully updated. I'm using zypper dup to update my system. I noticed that there's no any problem with printing jpeg or png files when I'm using epson or gutenprint drivers. I checked gwenwiew and okular.

broadstairs
Posts: 73
Joined: Thu Nov 04, 2010 11:50 am

Re: PNG, JPEG not printing using Turboprint

Post by broadstairs » Thu Jan 10, 2019 9:20 am

I guess it must be the Epson drivers then as I no longer have an Epson I cant help further.

Stuart

zedonet
Site Admin
Posts: 1756
Joined: Fri Oct 06, 2006 8:02 am

Re: PNG, JPEG not printing using Turboprint

Post by zedonet » Tue Jan 22, 2019 10:01 am

Hello,

I could reproduce the problem under the current SuSE Tumbleweed - the Ghostscript version that comes with TurboPrint fails with the PDF file that gwenview sends for the print job. (The PDF file actually seems to be incorrect, Adobe Acrobat DC on Windows cannot display it).

We will try to find a solution for the upcoming new TurboPrint version.

broadstairs
Posts: 73
Joined: Thu Nov 04, 2010 11:50 am

Re: PNG, JPEG not printing using Turboprint

Post by broadstairs » Thu Jan 24, 2019 10:21 am

I am intrigued that you can reproduce this error. I use Tumbleweed and have just printed a jpeg image perfectly using Turboprint from Gwenview. My system is fully updated and I'm using Gwenview 18.12 with ghostscript 9.26-1.1 and TP 2.47-1.

Stuart

Florrens
Posts: 1
Joined: Wed Apr 03, 2019 9:21 am

Re: PNG, JPEG not printing using Turboprint

Post by Florrens » Thu Apr 04, 2019 1:20 pm

Should I perform an update? Is the version with the fix for this out? Ran into this problem on one of my older machines.

zedonet
Site Admin
Posts: 1756
Joined: Fri Oct 06, 2006 8:02 am

Re: PNG, JPEG not printing using Turboprint

Post by zedonet » Mon Apr 08, 2019 7:54 am

TurboPrint 2.47-1 is the version with the fix - if you are currently using an older version, I recommend the update.

Post Reply