SOLVED - Turboprint Monitor stopped working

Linux distribution specific questions
Post Reply
steve
Posts: 7
Joined: Thu Apr 29, 2010 12:16 pm

SOLVED - Turboprint Monitor stopped working

Post by steve » Sun Feb 03, 2013 6:10 pm

I loaded Turboprint 2.26-1 on my computer about a year ago and it worked fine until a couple weeks ago. Now the Turboprint Monitor doesn't seem to see anything I send to the printer. Even when I try to run a test print from the Print Control. Everything seems to print out fine but the monitor just doesn't respond to anything. It doesn't see the job while it's printing. The Preview doesn't show anything. And the Print Monitor won't start when I send a print to the printer. Everything was working great till several weeks ago. I checked all the settings. The daemon starts on boot like it should. Everything is configured according to the instructions. The only thing left is the CUPS files. I had to reinstall them a while ago, but I didn't notice any problem with Turbo Print then.

Something may not be right with them, but they look okay to me, these are the CUPS files I have installed;
CUPS
CUPS-COMMON
CUPS-DRIVERS
CUPS-PDF

Are there any other files that should be there for Turboprint to work the way it did before?
This is a problem, the program was working great.
Thank you,

Stephen
se2009@comcast.net
PCLinuxOS 2012
LXDE
Last edited by steve on Wed Feb 20, 2013 6:12 pm, edited 1 time in total.

zedonet
Site Admin
Posts: 1908
Joined: Fri Oct 06, 2006 8:02 am

Re: Turboprint Monitor stopped working

Post by zedonet » Tue Feb 12, 2013 5:58 pm

Hello,

could you please post some additional information:

- your printer model
- the printer "URI" as visible in TurboPrint Control, column "URI"
- did the problem occur after upgrading your Linux distribution?
- please also post the log file /var/log/turboprint/print.log

steve
Posts: 7
Joined: Thu Apr 29, 2010 12:16 pm

Re: Turboprint Monitor stopped working

Post by steve » Fri Feb 15, 2013 6:32 pm

Hello; Thanks for contacting me about this.
1) Printer is a Canon PIXMA iP4200
2) Printer URI is tpu://Canon/iP4200
3)This problem started about a week after I re-installed the OS. I was able to print okay after I re-installed OS at least one time then the monitor stopped showing info. I did reconfigure Turboprint but that didn't help.
4)This is a long file;


/var/spool/turboprint/stephen/iP4200-TurboPrint.1.job
------------ End of print job - result = 0 ------------
job cancelling procedure - TPPID=2637 GSPID=2639 PVPID=
------------ END of tpprint filter ------------

#######################################################
NEW PRINT JOB Fri Feb 15 12:38:33 EST 2013 (pstoturboprint 2.23-1)
job-id 31

...
This post was shortened, as no problems were visible in the log file
...

------------ End of print job - result = 0 ------------
job cancelling procedure - TPPID=3603 GSPID=3605 PVPID=
------------ END of tpprint filter ------------


I hope this helps. I really like Turboprint and recommended to all my computer friends, I would hate to not be able to use it.

Thank you,
Stephen

zedonet
Site Admin
Posts: 1908
Joined: Fri Oct 06, 2006 8:02 am

Re: Turboprint Monitor stopped working

Post by zedonet » Mon Feb 18, 2013 9:36 am

Thank you for the log file. No problem was visible there, so I still cannot tell where the problem comes from.

Could you please try if the problem is still present with the current TurboPrint version. The latest Beta version 2.29-1beta also fixes a USB problem under Ubuntu 12.10, however this probably relevant for PCLinuxOS 2012.

The download link is for 32bit systems

ftp://ftp.zedonet.com/tp2/turboprint-2. ... a.i586.rpm

and for 64bit systems

ftp://ftp.zedonet.com/tp2/turboprint-2. ... x86_64.rpm

If you install this version, please let me know if it helps.

steve
Posts: 7
Joined: Thu Apr 29, 2010 12:16 pm

Re: Turboprint Monitor stopped working

Post by steve » Wed Feb 20, 2013 3:00 am

Thank you for the reply. I removed the 2.26-1 version I had installed on my computer then installed the 2.29-1beta copy 32 bit turboprint. I ran several tests and it seems to be working alright. When I tell a program to run a print the Turboprint Control and Monitor windows both open. A preview shows up for my approval then it show amount of job done as it prints. This is a beta copy. How long will it be usable? Should uninstall the beta copy and go back to my original version 2.26-1?
Thank you,
Stephen

zedonet
Site Admin
Posts: 1908
Joined: Fri Oct 06, 2006 8:02 am

Re: Turboprint Monitor stopped working

Post by zedonet » Wed Feb 20, 2013 9:38 am

Good to hear that your problems are solved. You can use the beta version like a normal release of TurboPrint. Today V2.29 will be released, so you are also free to download and install it over your beta installation.

steve
Posts: 7
Joined: Thu Apr 29, 2010 12:16 pm

Re: SOLVED - Turboprint Monitor stopped working

Post by steve » Wed Feb 20, 2013 6:14 pm

Thank you for all your help and prompt reply.
Stephen

Post Reply