Unable to send data to printer

Linux distribution specific questions
Post Reply
MathSWE
Posts: 3
Joined: Thu Sep 05, 2013 7:20 pm

Unable to send data to printer

Post by MathSWE » Thu Sep 05, 2013 7:24 pm

Hi All!

Really hoping to get the driver working!

Im running Ubuntu 13.04, everything updated. When I try to print I can see the image starting to appear in the TurboPrint Printer Monitor, and the printer LED is blinking green. But after about 10-15% it stops with the error messade "Unable to send data to printer". (The printer LED is still blinking, though...)

The printer is a Canon PIXMA PRO9000 MkII.

Any ideas of how to fix this?

Best regards from Sweden!

zedonet
Site Admin
Posts: 1907
Joined: Fri Oct 06, 2006 8:02 am

Re: Unable to send data to printer

Post by zedonet » Fri Sep 06, 2013 9:29 am

Hello,

please try the following:

1. Make sure that the "TP-USB" Backend has been chosen in TurboPrint Control Center. Open TurboPrint Control and check if the column "URI" starts with "tpu..." and not with "usb...". If it starts with "usb...", click on "Edit" and choose the port entry "Canon Pro9000 ... TP-USB" (not "Canon Pro 9000 ... USB") and click on "OK" to save the configuration.

2. If you still have printing problems, try the following (only if you have some experiences with a text editor and altering system files as superuser):
Edit the file

/etc/turboprint/system.cfg

and add the line "USB_MODE=0". In case this line was already present (e.g. USB_MODE=1) just alter it.

Please let me know if this helps.

MathSWE
Posts: 3
Joined: Thu Sep 05, 2013 7:20 pm

Re: Unable to send data to printer

Post by MathSWE » Fri Sep 06, 2013 12:34 pm

Switching to the TP-USB worked like a charm!

THANKS! : :mrgreen: You are so getting my money!

Have a nice weekend!!

Simon
Posts: 1
Joined: Fri Sep 06, 2013 3:07 pm

Re: Unable to send data to printer

Post by Simon » Fri Sep 06, 2013 3:11 pm

Worked for me on Debian Wheezy 64. Many thanks.

zedonet
Site Admin
Posts: 1907
Joined: Fri Oct 06, 2006 8:02 am

Re: Unable to send data to printer

Post by zedonet » Mon Sep 09, 2013 9:42 am

Thank you for the reply!

We are still trying to figure out what caused the problem, so it would be helpful if you could send the following additional information:

1. is the printer attached directly to the computer's USB port or is there a USB switch or USB hub plugged in between?

2. does printing work properly if you change the printer configuration in TurboPrint Control: click on "Edit" and choose the port entry "... USB" instead of "... TP-USB" and click on "OK" to save the configuration.

3. only @Simon: which printer model do you have?

MathSWE
Posts: 3
Joined: Thu Sep 05, 2013 7:20 pm

Re: Unable to send data to printer

Post by MathSWE » Mon Sep 09, 2013 8:27 pm

Hi again!

1. The printer is connected to a USB port in a extra 4-port USB card on my stationary PC.
2. It only works with TP-USB. It was set to only USB before.

Let me know if you need more information for debugging!

Thnx again!!!

Post Reply