tpdaemon stops in ubuntu 14.04

Linux distribution specific questions
boblennon
Posts: 1
Joined: Sun Dec 27, 2015 5:47 pm

tpdaemon stops in ubuntu 14.04

Post by boblennon » Sun Dec 27, 2015 5:57 pm

I recieve an internal error that tpdaemon has stopped. Then status monitor wont work. I can restart the tpdaemon but in a few minutes it will stop again. Problem is happening on two ubuntu 14.04 computers, one is a 32bit and the other is a 64bit.

zedonet
Site Admin
Posts: 1907
Joined: Fri Oct 06, 2006 8:02 am

Re: tpdaemon stops in ubuntu 14.04

Post by zedonet » Fri Jan 01, 2016 4:47 pm

Hello,

which printer do you use and how is it connected (USB / Network)?

Please also send the "URI" which is visible in TurboPrint Control, main window, table column "URI".

spinor
Posts: 4
Joined: Wed Jul 22, 2015 1:55 pm

Re: tpdaemon stops in ubuntu 14.04

Post by spinor » Sun Jan 03, 2016 6:11 pm

I have this exact same problem (under Fedora 20, already reported). Hoping it can be resolved before my access to updates expires next month.

zedonet
Site Admin
Posts: 1907
Joined: Fri Oct 06, 2006 8:02 am

Re: tpdaemon stops in ubuntu 14.04

Post by zedonet » Mon Jan 04, 2016 4:47 pm

Hello spinor,

I also need your answer to the same question
which printer do you use and how is it connected (USB / Network)?

Please also send the "URI" which is visible in TurboPrint Control, main window, table column "URI".
Thanks!

spinor
Posts: 4
Joined: Wed Jul 22, 2015 1:55 pm

Re: tpdaemon stops in ubuntu 14.04

Post by spinor » Mon Jan 04, 2016 6:53 pm

I have the Canon iP8750 and MG7550. Problem only occurs when a printer (either one) is on and connected via network. Seems to be OK via USB. Also, tpdaemon only dies if the status monitor is open. Without the status monitor, the daemon stays alive. If I close the status monitor quickly enough (within a few seconds) I can usually keep tpdaemon going.

URI:
dnssd://Canon%20MG7500%20series._ipp._tcp.local/?uuid=00000000-0000-1000-8000-D8492FDD79C5

(Sorry, I meant to say Fedora 22 in my previous post, rather than 20).

bernecky
Posts: 10
Joined: Thu Apr 21, 2016 5:50 pm

Re: tpdaemon stops in ubuntu 14.04

Post by bernecky » Thu Apr 21, 2016 6:00 pm

I am running Ubuntu 14.04LTS. I observe the same tprint daemon sigsegv problem when I print anything, on a CANON PIXMA Pro 100.
Ubuntu has latest patches.

The URI for the printer is: bjnp://94a580000000.local:8611.

The printer is connected via wifi.

Suggestions welcome.

bernecky
Posts: 10
Joined: Thu Apr 21, 2016 5:50 pm

Re: tpdaemon stops in ubuntu 14.04

Post by bernecky » Sat Oct 01, 2016 7:41 pm

No reply on this issue since April.

Failures still happening.

Printer is connected via wi-fi.

Suggestions welcome!

zedonet
Site Admin
Posts: 1907
Joined: Fri Oct 06, 2006 8:02 am

Re: tpdaemon stops in ubuntu 14.04

Post by zedonet » Thu Oct 06, 2016 7:58 am

Sorry for the delay! We could not reproduce the problem at that time, but will try to solve it now.
Can you do some testing if it might become necessary to send you a special debug version of tpdaemon?

zedonet
Site Admin
Posts: 1907
Joined: Fri Oct 06, 2006 8:02 am

Re: tpdaemon stops in ubuntu 14.04

Post by zedonet » Fri Oct 07, 2016 1:44 pm

As a first step it would be helpful if you could create a log file.
Please open a "Terminal" window and enter the following lines (each line followed by the "Enter" key, sudo will prompt you to enter your login password):

sudo killall tprintdaemon
sudo tprintdaemon 255 > tprintdaemon.log

When the TurboPrint daemon stops running (visible in TurboPrint Monitor or at the command line), please send the logfile tprintdaemon.log by email to mail <at> zedonet <dot> com.

bernecky
Posts: 10
Joined: Thu Apr 21, 2016 5:50 pm

Re: tpdaemon stops in ubuntu 14.04

Post by bernecky » Thu Jan 05, 2017 6:47 pm

Sorry to take so long to get back to you; I've been busy and/or out of town.

I tried running the tprintdaemon 255, and printed about 30 jobs, but it has not
crashed. I'll see if I can get a more reproducible failure out of the thing.

Robert

bernecky
Posts: 10
Joined: Thu Apr 21, 2016 5:50 pm

Re: tpdaemon stops in ubuntu 14.04

Post by bernecky » Sun Jan 08, 2017 8:25 pm

I was unable to get the "255" invocation of tprintdaemon to fail for several days, but today,
it failed while printing part of a LibreOffice Calc spreadsheet (not running the 255 version, of course...).

Here are some parts of the Ubuntu "...experienced an internal error" report on my
screen:

Package turboprint 2.40-1 [modified...]

Apport Version 2.20.1--ubuntu2.4

SegvReason: writing VMA/lib/x86_64-linux-gnu/libnss_files-2.23.so
Signal 11

If you want to send me a debug version of turboprint for fault isolation,
I can run that.

Robert

zedonet
Site Admin
Posts: 1907
Joined: Fri Oct 06, 2006 8:02 am

Re: tpdaemon stops in ubuntu 14.04

Post by zedonet » Fri Jan 13, 2017 10:48 am

Thank you for sending the crash report information. We have made some changes in TurboPrint 2.41 that might solve the problem, but I am not sure if it actually fixes it. If you have time to install the new version, please let me know if it works reliably.

bernecky
Posts: 10
Joined: Thu Apr 21, 2016 5:50 pm

Re: tpdaemon stops in ubuntu 14.04

Post by bernecky » Fri Jan 13, 2017 7:55 pm

Thank you. I have installed 2.41, and will let you know if it works better/worse/different.

Robert

bernecky
Posts: 10
Joined: Thu Apr 21, 2016 5:50 pm

Re: tpdaemon stops in ubuntu 14.04

Post by bernecky » Fri Feb 03, 2017 3:53 pm

I have not observed any more crashes since I installed the new driver.
Thank you!

I do note that printing speed on the Canon PIXMA Pro 100 seems much slower
now. E.g., printing a simple text file takes about 2 minutes. Perhaps I have
screwed up the install?

Robert

zedonet
Site Admin
Posts: 1907
Joined: Fri Oct 06, 2006 8:02 am

Re: tpdaemon stops in ubuntu 14.04

Post by zedonet » Mon Feb 06, 2017 5:54 pm

Hello bernecky,

thank you for your positive feedback.
Is the URI for your canon printer still "bjnp://94a580000000.local:8611"? There have been no changes in the BJNP backend in the last months, so printing speed should not have changed. Maybe printing is slower because you selected a different network protocol?

Post Reply