Canon MP600 / Ubuntu Xenial: Alternate groups of lines not printing. Help please!

Linux distribution specific questions
Post Reply
dave67
Posts: 1
Joined: Sun Aug 19, 2018 10:44 am

Canon MP600 / Ubuntu Xenial: Alternate groups of lines not printing. Help please!

Post by dave67 » Sun Aug 19, 2018 11:12 am

Hi

I bought an old but "as new" unused and boxed Canon MP600 all-in-one printer-scanner 3 months ago.

My laptop is running Linux running Peppermint 6 (Ubuntu Xenial) Linux (386).
I was unable to get the laptop to print using the built-in Linux printer drivers.
Canon's recommended MP600 drivers for Linux have since been withdrawn from Canon's website, so are no longer available to download.

I therefore purchased a fully registered version of TurboPrint 2 for Linux version 2.54-1 in February.
Until about a month ago, TurboPrint worked great with the MP600 (and also gave me a lot of additional printing and formatting options which Ubuntu's drivers did not offer).
The printer was working fine and printing both documents and images with no problems.

Now, all of a sudden, it is not working properly.
The printer will print two or three lines of text, but then skip the next two or three and so on, down the page.
This happens regardless of whether the document to be printed is a .pdf or plain text file; or whether I use colour or black and white only print options.

All the ink cartridges are full and are authentic Canon products.
I've done thorough head/nozzle/roller checks and maintenance on the MP600:
All test are OK, and the test pages print fine in full colour with no skipped lines or alignment problems.

I therefore think it might be a software compatibility problem with TurboPrint; perhaps as a result of the most recent Ubuntu system upgrade about one month month ago ; the same time as the problem began.

I've checked all the printer settings in TurboPrint and Ubuntu, but I can't find a way to solve the problem by changing any of these from defaults.

The only thing I haven't tried yet is removing and re-installing TurboPrint, as I am not sure how to fully and safely uninstall it, and if I might accidentally invalidate my purchased registration license by doing so.

I need the printer urgently for work assignments, and would be very grateful for any help you could give me to get it up and running again as soon as possible.

Many thanks in anticipation.


David Williams
(Swansea, UK)

zedonet
Site Admin
Posts: 1907
Joined: Fri Oct 06, 2006 8:02 am

Re: Canon MP600 / Ubuntu Xenial: Alternate groups of lines not printing. Help please!

Post by zedonet » Tue Aug 21, 2018 11:06 am

Hello,

this is a rather uncommon problem and might be caused by a print head or printer mechanicas problem.

Can you please post a scan or photo of a printed document that shows the problem and also of the printer's nozzle test page?

Post Reply