printing stops before job is finished

Post Reply
David Brown
Posts: 4
Joined: Sun May 06, 2012 4:59 pm

printing stops before job is finished

Post by David Brown » Mon Jun 04, 2012 12:26 am

Linux Mint 9 and now Linux Mint 13 (amd64 version), TurboPrint 2.24-1 (amd64), Epson Stylus Pro 3800, USB connection

Problem: printing stops after some variable amount of printing. See the attached screen capture. This started happening about a year ago, and I thought the printer was going bad. I replaced the USB cable, but that did not help. Then I tried printing from Windows (in a VirtualBox virtual machine, in Linux) on this same computer, and this works reliably. My conclusion is that my problem is TurboPrint related.

Normally I print to this printer fron the Gimp, using the TurboPrint Gimp plugin. Printing from the Gimp, not using the plugin, gives the same results.

Looking for a solution on the TurboPrint forums, I found a suggestion that files remaining from an old installation of TurboPrint could interfere with a newer installation, so i deinstalled TurboPrint, removed all folders and files relating to TurboPrint, and then reinstalled. No success.

I attach a screenshot from a recent print attempt. Printing was from the Gimp using the TurboPrint Gimp plugin. Printing started then stopped. The TurboPrint Printer Monitor reported a USB error. Running lsusb in the Terminal shows the printer connected.

David Brown

David Brown
Posts: 4
Joined: Sun May 06, 2012 4:59 pm

Re: printing stops before job is finished

Post by David Brown » Mon Jun 11, 2012 6:06 pm

Here's the screenshot the previous message refers to.
Attachments
Screenshot.jpg
Screenshot.jpg (133.74 KiB) Viewed 7357 times

zedonet
Site Admin
Posts: 1800
Joined: Fri Oct 06, 2006 8:02 am

Re: printing stops before job is finished

Post by zedonet » Tue Jun 12, 2012 10:18 am

Hello,

please open TurboPrint Control and check which USB printer backend is shown in the list of printers, column "URI".

If the URI starts with "usb://", the original CUPS backend for USB printers is used, if it starts with "tpu://", the TurboPrint version is used that allows printer status reports during printing.

You can try if printing works more reliably after exchanging the USB backend. To do this, press "Edit" in TurboPrint Control. Then select a different entry in the list "Choose port" - "Epson Stylus Pro 3800 TP-USB" ("tpu://"-Backend) instead of "Epson Stylus Pro 3800" ("usb://"-backend) or vice versa.

David Brown
Posts: 4
Joined: Sun May 06, 2012 4:59 pm

Re: printing stops before job is finished

Post by David Brown » Fri Jul 20, 2012 5:49 pm

Sorry for the long delay. Between my last post and this one I moved across the continent.

In the Turboprint Control Center, the URI is usb://EPSON/Stylus%20Pro%203800?serial=MP050612120638340 Epson_StylusPro3800

When I select Edit, the TurboPrint - add / edit printer box shows:
Printer is: standard printer
Choose Port: Other
URI: usb://EPSON/Stylus%20Pro%203800?serial=MP0520612120638340

The only other options in Choose port are parallel printer 1 and parallel printer 2. No option "Epson Stylus Pro 3800 TP-USB" ("tpu://"-Backend)" appears.

zedonet
Site Admin
Posts: 1800
Joined: Fri Oct 06, 2006 8:02 am

Re: printing stops before job is finished

Post by zedonet » Mon Jul 30, 2012 10:33 am

Hello,

I also apologize for the delay!

You could try the following:

Select "Edit" in TurboPrint Control
Change "URI" to "tpu://EPSON/Stylus_Pro_3800"

Then press "OK" to save settings and try to print again.

If that doesn't help - is the amount of printed output shown in TurboPrint Monitor similar to the actual print progress?
Or doesn't the printer actually start printing?

David Brown
Posts: 4
Joined: Sun May 06, 2012 4:59 pm

Re: printing stops before job is finished

Post by David Brown » Thu Aug 30, 2012 8:21 pm

As suggested, I set "URI" to "tpu://EPSON/Stylus_Pro_3800". With that setting TurboPrint did not "see" the printer. I deleted the printer (in TurboPrint Control) and then reloaded it, letting TurboPrint find it.

I then printed a test page, successfully, twice. In both cases the TurboPrint Monitor showed the printer "not connected or switched off". It also showed a spooler message "printing page 1, 78% complete...", while the printer printed happily away. I attach a screenshot to show this. In both cases, the test page printed successfully.

David Brown
Screenshot-1.jpg
Screenshot-1.jpg (234.35 KiB) Viewed 7269 times

zedonet
Site Admin
Posts: 1800
Joined: Fri Oct 06, 2006 8:02 am

Re: printing stops before job is finished

Post by zedonet » Thu Sep 06, 2012 1:26 pm

Using the "usb://" URI means that the standard USB backend from CUPS is used as port driver. This driver blocks access to the attached printer for TurboPrint, thus it does not see the printer. Using the alternative TP-USB port driver (shown as "tpu://" in the URI) allows printer monitoring while printing. On some Linux systems tpu does not get the correct serial number of the printer and thus cannot identify it when a print job is sent. In such cases it helps to just remove the serial number part of the URI (e.g. "/SN=123812738").

Post Reply