Gwenview print error with Turboprint trial version

Post Reply
m_pav
Posts: 4
Joined: Sun Mar 01, 2009 2:25 am

Gwenview print error with Turboprint trial version

Post by m_pav » Wed Mar 11, 2009 8:38 am

When I try to print anything from Gwenview to my PIXMA MP750 using the latest Turboprint driver, I get the following error. If I change to a different driver or printer, the image prints just fine. I just booted into my testing partition with the identical setup, installed the older 1.94 driver and had no errors at all.

Catastrophe!
A print error occurred. Error message received from system:
Error while reading filter description for TRUE. Empty command line received

I am running SimplyMEPIS version 8 64-bit.

Is this a bug?

zedonet
Site Admin
Posts: 1885
Joined: Fri Oct 06, 2006 8:02 am

Post by zedonet » Wed Mar 11, 2009 9:20 am

Hello,

this sounds like a known problem with the KDE print system when printing from KDE applications or from command line with the "kprinter" command.

This problem can occur with TurboPrint 1 & 2 (and probably any other printer driver).

If this is the case, please try the following:

Open the KDE menu "utilities" / "printing" / "printing manager"
(this module is also accessible from KDE control center).

Click on "tp0" (or choose the entry for the TurboPrint printer)
Open the "instances" index card
Click on "settings"
Open the "filters" index card

Delete all "filters" entries.

If there are none, there may be application specific filter settings - please try the same from your application program's print dialog.

m_pav
Posts: 4
Joined: Sun Mar 01, 2009 2:25 am

Thank you

Post by m_pav » Wed Mar 11, 2009 11:09 pm

That seems to have done it. I can't see the printout because I accessed the machine remotely and nobody is at home, but no error message was given.

I'm not sure how the filter got in there in the first place, possibly me trying to get printing to CD sorted, but AFAIK, I never touched the filters area at any time. One to chalk up to experience.

Thank you

Mike P

Post Reply