Page 1 of 1

Serious Problems with the Network Installation

Posted: Thu Jan 30, 2020 10:11 pm
by mr_spock123
I'm currently trying to see if we can use printFab in the office with a client machine and a windows machine that shares the device with windows shares. However I'm having a lot of issues, while with normal windows sharing it works, accessing from PrintFab seems to be impossible.

Here's my setup:

machine_a (192.168.0.1) is the machine with printer usb connected (Windows 7 Pro)
machine_b (192.168.0.2) is the client (Windows 7 Pro)

on machine_b the client i installed PrintFab

the printer is a Canon 9500 Mk II and i shared it from device and printers, share this printer with the name "pro9500"

in order to have no extra throubles I disabled Windows Firewall (domain, home, public) both on machine_a and machine_b

On printfab I select add printer -> windows sharing

there's one only field: printer/server
and the print queue (??)

I tried:

- printer/server: "192.168.0.1/pro9500"
- printer queue: ""
not working

- printer/server: "pro9500/192.168.0.1" ---> (because you know if it's written printer/server I take it literally and write before the printer name, then a slash without spaces and then again the ip address of the server)
- printer queue: ""
but the same not working

- printer/server: "192.168.0.1"
- printer queue: "pro9500"
not working
tried this way because sometimes i found print queue automatically added as slash after the server name hoping to achieve the resource link \\192.168.0.1\pro9500

Nothing worked, also..

If kept active the details checkbox I got errors raging from:
- Access Denied -> partially solved running the PrintFab as Administrator
- Errors involving the modules that can't be put down or up because already in use

For finish: I don't know how clicking randomly I managed one time to create the printer but not working, to found that only if you are able to add the actual device you have WORKGROUP, USERNAME, PASSWORD fields.. When you add the printer from the Plus icon you have not the username and password fields, how a person is supposed to access to the remote printer if you can't specify the actual username and password ? Even setting everyone as permission it would be impossibile to use Guest as account not having the username field.

Tried also the common username:password@host and username:password@host:port where port were the common SMB ports, nothing worked.

If you want I could try to do additional tests but it seems there's some kind of major bugs preventing me to access the remote printer or I do not know the exact syntax / documentation..

Thanks for your support in advance :)

Re: Serious Problems with the Network Installation

Posted: Thu Feb 13, 2020 10:21 am
by mr_spock123
Up, can I get some help guessing what's wrong in this network test setup ?

Best Regards...

Maybe I'm doing it wrong by choosing the windows share for the printer? Maybe it Isn't the correct procedure ?

Re: Serious Problems with the Network Installation

Posted: Thu Feb 13, 2020 1:49 pm
by zedonet
Hello and sorry for not getting back to you earlier.

The following setup is the right one:
- printer/server: "192.168.0.1"
- printer queue: "pro9500"
If you have trouble setting up the windows printer sharing connection, you can alternatively use LPD.
First you have to add the LPD Print Service option on the server

printfab-windows-lpd-print-service.PNG
printfab-windows-lpd-print-service.PNG (18.98 KiB) Viewed 1053 times

then setup hte printer on the client (printer/server: "192.168.0.1" printer queue: "pro9500") but select "Network printer LPD" instead of "Windows network printer".
Finally, you have to disable the SNMP Status option for the PrintFab printer entry on the client

printfab-windows-lpd-disable-snmp.PNG
printfab-windows-lpd-disable-snmp.PNG (40.69 KiB) Viewed 1053 times