Turn off Duplex Print

Other questions
Post Reply
djk123
Posts: 3
Joined: Sat Mar 29, 2014 8:25 pm

Turn off Duplex Print

Post by djk123 » Sat Mar 29, 2014 8:41 pm

I have a Canon Pixma iP3600. Every time I print to it, Turboprint shows a "Manual Duplex" pop-up. This printer will is not capable of duplex printing, and I use another printer for duplex (Canon Pixma MX920). The standard Linux print settings for the 3600 printer do not include the "duplex" option, but Turboprint does. Is there any way to disable this pop-up window?

I'm using Linux Mint 13.

Thanks.

zedonet
Site Admin
Posts: 1777
Joined: Fri Oct 06, 2006 8:02 am

Re: Turn off Duplex Print

Post by zedonet » Mon Mar 31, 2014 11:03 am

Hello,

please try to follow the instructions that we posted in this similar thread and let me know if this solves the problem:

http://www.turboprint.info/support/view ... 833&p=2632

mdavies5
Posts: 1
Joined: Thu Apr 09, 2015 9:05 am

Re: Turn off Duplex Print

Post by mdavies5 » Fri May 29, 2015 1:56 am

I had this same problem with my Epson XP310. I solved it by commenting out the following lines in the .ppd file:
*%Duplex DuplexNoTumble/Manual (portrait): "<</zedoDuplex(DuplexNoTumble)>>pop <</Duplex true /Tumble false>>setpagedevice"
*%Duplex DuplexTumble/Manual (landscape): "<</zedoDuplex(DuplexTumble)>>pop <</Duplex true /Tumble true>>setpagedevice"

After playing around with the .ppd file I realised that this is probably by choice. Although duplex is turned off the default dialog detects a multipage document and defaults the "Two Sided" option to "Long Edge". The user then has the option to reselect "Single Sided".
Unfortunately you can only permanently enable/disable duplex by editing the .ppd file.
The problem with the Turboprint dialog is: If you set "Duplex" to "Off", you still have a "Duplex Mode" option with choices of "Manual" or "Manual Reverse". This should be modified to set "Duplex Mode" to "Off". Although I cannot see any purpose for the 2 options "Duplex" and "Duplex Mode", surely this is a duplication.

Post Reply