Canon Pixma IP4700 doesn't print on CD's

Other questions
Post Reply
nkukard
Posts: 4
Joined: Tue May 11, 2010 6:42 pm

Canon Pixma IP4700 doesn't print on CD's

Post by nkukard » Tue May 11, 2010 6:48 pm

I've tried combination of the settings...

CD Printable + Auto
CD Printable + CD Tray
Plain Paper + CD Tray

No success, printer doesn't even blink. It seems to be flat out ignoring the print job if sent to the CD tray. No matter how many jobs you send, they come up as success but nothing happens on the printer at all.

If I select plain paper auto, it prints my label on a piece of paper fine. Printing plain paper with the CD in the tray obviously generates a 6 blink flash error.

I used to use my PiXMA ip4300 with no problems at all with Gutenprint, but it died today.

zedonet
Site Admin
Posts: 1775
Joined: Fri Oct 06, 2006 8:02 am

Post by zedonet » Wed May 12, 2010 8:27 am

Hello,

can you please post the log file /var/log/turboprint/print.log after trying to print on CD - just post the part for the last print job starting from "### new print job".

nkukard
Posts: 4
Joined: Tue May 11, 2010 6:42 pm

Post by nkukard » Wed May 12, 2010 7:22 pm

Is this what you're after?

I tried very many print jobs, the result of them are the same though.

Regards
Nigel

#######################################################
NEW PRINT JOB Tue May 11 18:45:19 GMT 2010 (pstoturboprint 2.15-1)
job-id 10540
user nkukard
title Untitled1
copies 1
options InputSlot=AutoSelect job-uuid=urn:uuid:b032746e-d8a7-3015-552b-b3039c3b16a8 lease-duration=300 MediaType=CDprintable_4 PageSize=A4
file
queue tp0
test directory access:
drwxr-xr-x 2 root root 20480 May 11 18:05 /usr/share/turboprint/printers
linux-gate.so.1 => (0xb7f04000)
libm.so.6 => /lib/libm.so.6 (0xb7eca000)
libc.so.6 => /lib/libc.so.6 (0xb7dad000)
/lib/ld-linux.so.2 (0xb7f05000)
/usr/bin/tpprint -v2 -l/var/log/turboprint/print.log --username=nkukard --ppdfile=/etc/cups/ppd/tp0.ppd --psfeatures '---InputSlot=AutoSelect' '---job-uuid=
urn:uuid:b032746e-d8a7-3015-552b-b3039c3b16a8' '---lease-duration=300' '---MediaType=CDprintable_4' '---PageSize=A4' /tmp/pstoturboprint22274.chunk /tmp/psto
turboprint22274.var
Searching PPD file and postscript header for options...
set_feature: setting ColorSpace to RGB
set_feature: unknown feature:ColorSpace
set_feature: setting PageSize to A4
set_feature: setting PageRegion to A4
set_feature: setting PaperDimension to A4
set_feature: unknown feature:PaperDimension
set_feature: setting ImageableArea to A4
set_feature: unknown feature:ImageableArea
set_feature: setting MediaType to Plainpaper_4
set_feature: setting InkType to Color_1
set_feature: setting Resolution to 600x600dpi
set_feature: setting InputSlot to AutoSelect
set_feature: setting OutputBin to Front
set_feature: setting Duplex to None
set_feature: setting zedoColorModel to RGB
set_feature: setting zedoDithering to ErrorDiffusion
set_feature: setting zedoMirror to 0
set_feature: setting zedoDuplexAdjust to 0
set_feature: setting zedoColorspace to 0
set_feature: setting zedoCMYKspace to 0
set_feature: setting zedoIntent to perception_0
set_feature: setting zedoIntensity to 0
set_feature: setting zedoBrightness to 0
set_feature: setting zedoContrast to 0
set_feature: setting zedoAdjustY to 0
set_feature: setting zedoAdjustM to 0
set_feature: setting zedoAdjustC to 0
set_feature: setting zedoAdjustK to 0
set_feature: setting zedoInklimitY to 0
set_feature: setting zedoInklimitM to 0
set_feature: setting zedoInklimitC to 0
set_feature: setting zedoInklimitK to 0
set_feature: setting zedoRefLight to 65
set_feature: setting zedoGreyToneA to 0
set_feature: setting zedoGreyToneB to 0
set_feature: setting zedoGamut to 0
set_feature: setting zedoUCR to 0
set_feature: setting zedoTAC to 0
set_feature: setting zedoBrightC to 0
set_feature: setting zedoBrightM to 0
set_feature: setting zedoDuplexadvanced to auto
set_feature: setting zedoBorderlessExpand to 2
set_feature: setting zedoSettingA to 0
set_feature: setting zedoSettingB to 0
set_feature: setting zedoSettingC to 0
set_feature: setting zedoPrinterDriver to Canon-PIXMA-iP4700
set_feature: setting to Canon-PIXMA-iP4700
set_feature: unknown feature:
set_feature: setting zedoLicenseType to License
set_feature: unknown feature:zedoLicenseType
set_feature: setting Font to Courier
set_feature: unknown feature:Font
set_feature: setting zedoPageRegion to A4
set_feature: setting zedoMediaType to CDprintable_4
set_feature: setting zedoCartridgeType to Color
set_feature: setting zedoInputSlot to AutoSelect
set_feature: setting zedoOutputBin to Front
set_feature: setting zedoColorModel to RGB
set_feature: setting zedoDithering to ErrorDiffusion
set_feature: setting zedoMirror to 0
set_feature: setting zedoDuplexAdjust to 0
set_feature: setting zedoColorspace to 0
set_feature: setting zedoCMYKspace to 0
set_feature: setting zedoIntent to perception_0
set_feature: setting zedoIntensity to 0
set_feature: setting zedoBrightness to 0
set_feature: setting zedoContrast to 0
set_feature: setting zedoAdjustY to 0
set_feature: setting zedoAdjustM to 0
set_feature: setting zedoAdjustC to 0
set_feature: setting zedoAdjustK to 0
set_feature: setting zedoInklimitY to 0
set_feature: setting zedoInklimitM to 0
set_feature: setting zedoInklimitC to 0
set_feature: setting zedoInklimitK to 0
set_feature: setting zedoRefLight to 65
set_feature: setting zedoGreyToneA to 0
set_feature: setting zedoGreyToneB to 0
set_feature: setting zedoGamut to 0
set_feature: setting zedoUCR to 0
set_feature: setting zedoTAC to 0
set_feature: setting zedoBrightC to 0
set_feature: setting zedoBrightM to 0
set_feature: setting zedoDuplexadvanced to auto
set_feature: setting zedoBorderlessExpand to 2
set_feature: setting zedoSettingA to 0
set_feature: setting zedoSettingB to 0
set_feature: setting zedoSettingC to 0
set_feature: setting zedoResolution to 600x600dpi
set_feature: setting zedoDuplex to None
set_feature: setting zedoPrinterDriver to Canon_PIXMA_iP4700
set_feature: setting InputSlot to AutoSelect
set_feature: setting job-uuid to urn:uuid:b032746e-d8a7-3015-552b-b3039c3b16a8
set_feature: unknown feature:job-uuid
set_feature: setting lease-duration to 300
set_feature: unknown feature:lease-duration
set_feature: setting MediaType to CDprintable_4
set_feature: setting PageSize to A4
check_flag_file: opening /var/turboprint/nkukard/prv/tp0
check_flag_file: opening /var/turboprint/nkukard/sml/tp0
----------- Start of var file -----------
ZEDOPARM="$ZEDOPARM zedoPageRegion=A4"
ZEDOPARM="$ZEDOPARM zedoMediaType=CDprintable_4"
ZEDOPARM="$ZEDOPARM zedoCartridgeType=Color"
ZEDOPARM="$ZEDOPARM zedoInputSlot=AutoSelect"
ZEDOPARM="$ZEDOPARM zedoOutputBin=Front"
ZEDOPARM="$ZEDOPARM zedoColorModel=RGB"
ZEDOPARM="$ZEDOPARM zedoDithering=ErrorDiffusion"
ZEDOPARM="$ZEDOPARM zedoMirror=0"
ZEDOPARM="$ZEDOPARM zedoDuplexAdjust=0"
ZEDOPARM="$ZEDOPARM zedoColorspace=0"
ZEDOPARM="$ZEDOPARM zedoCMYKspace=0"
ZEDOPARM="$ZEDOPARM zedoIntent=perception_0"
ZEDOPARM="$ZEDOPARM zedoIntensity=0"
ZEDOPARM="$ZEDOPARM zedoBrightness=0"
ZEDOPARM="$ZEDOPARM zedoContrast=0"
ZEDOPARM="$ZEDOPARM zedoAdjustY=0"
ZEDOPARM="$ZEDOPARM zedoAdjustM=0"
ZEDOPARM="$ZEDOPARM zedoAdjustC=0"
ZEDOPARM="$ZEDOPARM zedoAdjustK=0"
ZEDOPARM="$ZEDOPARM zedoInklimitY=0"
ZEDOPARM="$ZEDOPARM zedoInklimitM=0"
ZEDOPARM="$ZEDOPARM zedoInklimitC=0"
ZEDOPARM="$ZEDOPARM zedoInklimitK=0"
ZEDOPARM="$ZEDOPARM zedoRefLight=65"
ZEDOPARM="$ZEDOPARM zedoGreyToneA=0"
ZEDOPARM="$ZEDOPARM zedoGreyToneB=0"
ZEDOPARM="$ZEDOPARM zedoGamut=0"
ZEDOPARM="$ZEDOPARM zedoUCR=0"
ZEDOPARM="$ZEDOPARM zedoTAC=0"
ZEDOPARM="$ZEDOPARM zedoBrightC=0"
ZEDOPARM="$ZEDOPARM zedoBrightM=0"
ZEDOPARM="$ZEDOPARM zedoDuplexadvanced=auto"
ZEDOPARM="$ZEDOPARM zedoBorderlessExpand=2"
ZEDOPARM="$ZEDOPARM zedoSettingA=0"
ZEDOPARM="$ZEDOPARM zedoSettingB=0"
ZEDOPARM="$ZEDOPARM zedoSettingC=0"
ZEDOPARM="$ZEDOPARM zedoResolution=600x600dpi"
ZEDOPARM="$ZEDOPARM zedoDuplex=None"
ZEDOPARM="$ZEDOPARM zedoPrinterDriver=Canon_PIXMA_iP4700"
PDFFILE=0
GSPPDFOUND=1
GSCOLORMODE=2
GSXDPI=600
GSYDPI=600
GSWIDTH=4960
GSHEIGHT=7015
TPWIDTH=8268
TPHEIGHT=11693
TPXOFFSET=0
TPYOFFSET=0
DUPLEX=0
PREVIEW=0
NOPRINT=0
BORDERLESS=0
PVXDPI=87
PVYDPI=87
PVWIDTH=719
PVHEIGHT=1017
----------- End of var file -----------
tpstdin --parsedsc result=0
GSRESULT=ESP Ghostscript 8.15.4 (2007-03-14) GSVERSION=ESP GSMAJOR=8 GSMINOR=15 GSCUPSDEVICE=1
GSCOMMANDLINE=gs -sDEVICE=cups -r600x600 -dSAFER -dNOPAUSE -dBATCH
TPCOMMANDLINE=/usr/bin/tpprint --cups -v2 -l/var/log/turboprint/print.log -y1 --ppdfile=/etc/cups/ppd/tp0.ppd --psheader=/etc/cups/ppd/tp0.ppd '---InputSlot
=AutoSelect' '---job-uuid=urn:uuid:b032746e-d8a7-3015-552b-b3039c3b16a8' '---lease-duration=300' '---MediaType=CDprintable_4' '---PageSize=A4' '---zedoPageRe
gion=A4' '---zedoMediaType=CDprintable_4' '---zedoCartridgeType=Color' '---zedoInputSlot=AutoSelect' '---zedoOutputBin=Front' '---zedoColorModel=RGB' '---zed
oDithering=ErrorDiffusion' '---zedoMirror=0' '---zedoDuplexAdjust=0' '---zedoColorspace=0' '---zedoCMYKspace=0' '---zedoIntent=perception_0' '---zedoIntensit
y=0' '---zedoBrightness=0' '---zedoContrast=0' '---zedoAdjustY=0' '---zedoAdjustM=0' '---zedoAdjustC=0' '---zedoAdjustK=0' '---zedoInklimitY=0' '---zedoInkli
mitM=0' '---zedoInklimitC=0' '---zedoInklimitK=0' '---zedoRefLight=65' '---zedoGreyToneA=0' '---zedoGreyToneB=0' '---zedoGamut=0' '---zedoUCR=0' '---zedoTAC=
0' '---zedoBrightC=0' '---zedoBrightM=0' '---zedoDuplexadvanced=auto' '---zedoBorderlessExpand=2' '---zedoSettingA=0' '---zedoSettingB=0' '---zedoSettingC=0'
'---zedoResolution=600x600dpi' '---zedoDuplex=None' '---zedoPrinterDriver=Canon_PIXMA_iP4700' --jobid=10540 --username=nkukard '--title=Untitled1'
COMPLETEPIPE=/usr/share/turboprint/lib/tpstdin --paste /tmp/pstoturboprint22274.chunk | gs -sDEVICE=cups -r600x600 -dSAFER -dNOPAUSE -dBATCH -sOutputFile=/
tmp/pstoturboprint22274.fifo - >> /var/log/turboprint/print.log
PREVIEWPIPE=

zedonet
Site Admin
Posts: 1775
Joined: Fri Oct 06, 2006 8:02 am

Post by zedonet » Fri May 14, 2010 9:01 am

Thank you!

I still can't determine where the problem actually comes from.

Could you please send more information:

- from which application did you print
- send the log file /var/log/cups/error_log after trying to print to CD

As this log file can be quite long, please email to "mail at zedonet dot de" (replace at by @ and dot by .)

nkukard
Posts: 4
Joined: Tue May 11, 2010 6:42 pm

Post by nkukard » Fri May 14, 2010 11:06 am

printing using lpr and a postscript file.

I'll truncate all the logs, then send you the ps file plus all the logs.

I'm using the exact same ps I used for the Pixma IP4300, which uses the gutenprint ppd.

Give me a few hours to get the files for you.

-N

nkukard
Posts: 4
Joined: Tue May 11, 2010 6:42 pm

Post by nkukard » Mon May 17, 2010 6:08 am

Email sent.

awb57
Posts: 3
Joined: Wed Jun 23, 2010 12:53 pm

Same printer, TP Studio 2-15.2 and same problem

Post by awb57 » Sat Jun 26, 2010 2:21 am

Have upgraded from TP 2-06 to use new iP4700 and have the same problem.
Have followed instructions above and emailed my template and logs direct.

zedonet
Site Admin
Posts: 1775
Joined: Fri Oct 06, 2006 8:02 am

Post by zedonet » Wed Jun 30, 2010 7:55 am

Hello,

thank you for your feedback!

You wrote by email that after removing and adding the cartridge again it printed on CD, but the output was shifted to the lower right by 1cm.

So there may be two problems:

1. CD printing not working reliably
2. wrong position

About Problem 1:

Does it always take "two tries" to get something printed on a CD or is the behaviour "sporadic"?
We noticed with some Canon printers that the printer does not always recognize the CD tray, maybe because it doesn't find the position marks.

Problem 2:

There is a problem (bug?) in the current version of OpenOffice Draw that causes the output to be wrongly positioned - see also this thread:

http://www.turboprint.info/support/viewtopic.php?t=642

Possible workarounds are:

- increase page with or height in the page layout dialog, e.g. width = 14.1cm
- use a different application, e.g. OpenOffice Writer or GIMP

k.anderson3454
Posts: 1
Joined: Mon Dec 20, 2010 2:23 am

Re: Canon Pixma IP4700 doesn't print on CD's

Post by k.anderson3454 » Mon Dec 20, 2010 2:30 am

Why is this happening? I also experienced the same problem.
Last edited by k.anderson3454 on Fri Feb 04, 2011 12:28 am, edited 1 time in total.

zedonet
Site Admin
Posts: 1775
Joined: Fri Oct 06, 2006 8:02 am

Re: Canon Pixma IP4700 doesn't print on CD's

Post by zedonet » Mon Dec 20, 2010 10:39 am

Why is this happening? I also experienced the same problem.
Can you specify what your problem is, for example:

- CD tray not fed (orange printer LED flashes)
- CD printed, but not centered
- ...

Please include information on the application used for CD printing (e.g. OpenOffice, GIMP) and attach the log file /var/log/turboprint/print.log after trying to print on CD (section for last print starting from "### New print job" is sufficient).

Post Reply