printing borderless with lpr

Post Reply
marieeve83
Posts: 8
Joined: Fri Jun 01, 2007 5:57 pm

printing borderless with lpr

Post by marieeve83 » Fri Jun 01, 2007 6:06 pm

We installed Turboprint yesterday and it works correctly, but we have a problem in getting exactly what we want.

What we would like to do is print a borderless photo of 10 inch X 10 inch on roll paper by command line. We specified a custom size of 10.2x10.2inch but we didn't find how to specify borderless.

By using a photo viewer and a visual driver we were able to get almost what we wanted. The photo was borderless on both sides, but it was not on the top and bottom (even if we chose the "double cut" option).

By using lpr, we got only the top left quarter of the image... It was positionned at the bottom of the page, on the left side.

I tried modifying the /usr/share/turboprint/printers/Epson_StylusPro4800.tpp file by adding:
[Size26]
Name=10x10 borderless
Size=10200,10200
Margins=0,0,0,0
Param=0,0,0,0
But we get the same thing, except that it is centered.

We are usign an Epson Stylus Pro 4800 printer with a 10 inch roll paper.
We have the real version (not free) of TurboPrint.

Is there a way to print on borderless custom paper with lpr?

zedonet
Site Admin
Posts: 1831
Joined: Fri Oct 06, 2006 8:02 am

Post by zedonet » Mon Jun 04, 2007 10:13 am

Hello,

the modification should work as you described.

It might help to call the TurboPrint driver directly and send the output to a raw queue, e.g.

tpprint -dEpsonStylusPro4800 -s10200x10200 -q2 -m5 -f26 -i5 image.ppm - | lp -d tp0 -o raw

for CUPS or for lpr(ng):

tpprint -dEpsonStylusPro4800 -s10200x10200 -q2 -m5 -f26 -i5 image.ppm - | lpr -P tp0raw

where

-s10200x10200 is the print size
-q2 is the print quality (1440dpi)
-m5 is the media type (Epson Premium Glossy / Semiglossy)
-f26 the page size (the one you defined)
-i5 the paper feed mode (roll paper double cut)
image.ppm the input file (only ppm and pcx are supported, jpg must be converted first
- means send output to stdout

use "man tpprint" for more information.

marieeve83
Posts: 8
Joined: Fri Jun 01, 2007 5:57 pm

Re: printing borderless with lpr

Post by marieeve83 » Mon Jun 04, 2007 3:02 pm

I tried this and it didn't work correctly. The image is now of the good size and position (borderless) but the colors are... strange! Almost like negative or overexposed... Instead of being black, the background is a kind of pale red. I have tried many commands, with both lpr and lp, including one with all the color options:

tpprint -dEpson_StylusPro4800 -s10200x10200 -q3 -m5 -f26 -i4 -c0 -g2 -t0 -bt1b0o0s0i0g180y0m0c0k0 image.pcx - | lpr -P PrinterName

The result is always the same.

I have created the pcx and ppt files with image magick: convert name.png name.pcx When I look at the image with a viewer or gimp, the colors are ok so the problem does not seem to be due to the image file (and I've tried both .ppm and .pcx)

Thank you for your help!

zedonet
Site Admin
Posts: 1831
Joined: Fri Oct 06, 2006 8:02 am

Post by zedonet » Tue Jun 05, 2007 8:40 am

Sorry, there was a spelling error (missing "_" in the printer name).

Try

tpprint -dEpson_StylusPro4800 -s10200x10200 -q2 -m5 -f26 -i5 image.ppm -v2 ...

I have added "-v2" for debug information. If printout is still not okay, please cut & copy & post the terminal output.

marieeve83
Posts: 8
Joined: Fri Jun 01, 2007 5:57 pm

Re: printing borderless with lpr

Post by marieeve83 » Tue Jun 05, 2007 12:52 pm

I have tried:
tpprint -dEpson_StylusPro4800 -s10200x10200 -q3 -m5 -f26 -i4 -c0 -g2 -t0 -bt1b0o0s0i0g180y0m0c0k0 -v2 image.ppm - | lpr -P PrinterName

(I modified a little bit the options you mentionned to get the quality we want)

The output was:

tpprint 1.95-2 (26-JAN-2007) - TurboPrint printer driver
Copyright (C)ZEDOnet GmbH, Irsee, Germany. All rights reserved.
command level=19 feature set=7
Filetype=PBM Plusbits_per_pixel=32 bytes_per_line=18572 width=4643 height=4643
RGB Mode
Printer=Epson_StylusPro4800; Module=Epson; Id=PRO4800
Colormode=2; Cartridge=0=Photo Black; Quality=3=Photo; Paper=5=Epson Premium Glossy/Satin
Pagesize=26=10x10 borderless; Paper Input=4=Roll Paper (double cut); Paper Output=0=Front
Duplex=0=Off; Copies=1; Mirror=0; Dithering=0; Flip=0
Page x=29376 y=14688; AppDpi x=1440 y=1440; DitDpi x=2880 y=1440;
PrnDpi x=2880 y=1440; Overlay=0
Print Direction=Default (0:1,0,0,0); Drying Time=Off (1:2,0,0,0); Paper Thickness=Default (2:3,0,0,0); Paper Suction=Default (3:4,51,0,0); Eject Roller=Default (4:5,0,0,0); Cut Mode=Default (5:6,0,0,0); Print Separation Line=Off (6:7,0,0,0); Save Paper (Roll Paper)=Off (7:8,0,0,0);
tpfile::get_patchsample_table: paper=Epson Premium SemiGlossy Photo Paper S041624
patches; linmode=density
grey: a=0 b=0; colorspace=APPLE; cmykspace=0; intent=perceptual; daylight = 6500K
cmm::generate_memory_profile: multichannel_mode=TRUE
ucr_up=140; max_ink=510; ucr_add=38
cmm::generate_memory_profiles: 8 channels
polyfit mode=2 channels=4 terms=57 patches=169
polyfit mode=4 channels=4 terms=57 patches=395
init_cmyk2multichannel: c2fac=130 m2fac=191 k2fac=133 k3fac=272 max_ink=510
printer white:l=95 a-01 b-01
printer white poly:l=95 a-01 b-03
printer black:l=04 a-03 b+00
printer black poly:l=02 a+00 b-03
printer darkest poly:l=02 a+00 b-03
black l=00 a+00 b+00 => l=02 a+00 b-03: K99 C14 M14 Y14 c00 m00 k00 g00
black94 l=06 a+00 b+00 => l=10 a+00 b-02: K72 C31 M23 Y15 c00 m00 k01 g00
black87 l=17 a+00 b+00 => l=19 a+00 b-02: K50 C20 M16 Y08 c07 m06 k14 g00
black75 l=34 a+00 b+00 => l=34 a+00 b-03: K07 C02 M02 Y01 c16 m19 k41 g08
black62 l=48 a+00 b+00 => l=47 a+00 b-03: K00 C00 M00 Y00 c14 m16 k25 g32
black50 l=60 a+00 b+00 => l=58 a+00 b-03: K00 C00 M00 Y00 c09 m11 k09 g42
black37 l=71 a+00 b+00 => l=68 a+00 b-04: K00 C00 M00 Y00 c07 m08 k01 g39
black25 l=82 a+00 b+00 => l=77 a-01 b-04: K00 C00 M00 Y00 c04 m05 k00 g22
black12 l=91 a+00 b+00 => l=86 a-01 b-04: K00 C00 M00 Y00 c03 m03 k00 g06
white l=99 a+00 b+00 => l=95 a-01 b-03: K00 C00 M00 Y00 c00 m00 k00 g00
cyan l=89 a-54 b-17 => l=78 a-29 b-27: K00 C00 M00 Y00 c32 m00 k00 g00
magenta l=64 a+87 b-52 => l=60 a+63 b-15: K00 C00 M02 Y00 c01 m83 k00 g00
yellow l=97 a-14 b+86 => l=91 a-14 b+76: K00 C00 M00 Y45 c00 m00 k00 g00
red l=58 a+77 b+70 => l=52 a+64 b+55: K00 C00 M41 Y54 c00 m55 k00 g00
green l=86 a-84 b+72 => l=73 a-56 b+55: K00 C00 M00 Y48 c30 m00 k00 g00
blue l=32 a+60 b-105 => l=32 a+13 b-66: K00 C99 M03 Y00 c00 m27 k00 g00
epson::setup_printer_info: number of channels: 8
epson::setup_printer_info: bits per pixel: 1
Epson init string: ESC ( K 2 ESC U 0 ESC ( i 1 ESC ( e 5
epson::setup_printer_info: color nozzles:1 color spacing:1440 black nozzles:1 black spacing:1440
epson_info.top_feed=0 epson_info.top_margin=0 epson_info.bottom_margin=14688 epson_info.unit_y=1440 epson_info.y_pixel_units=1
esc(C 3960 esc(c 0 3960
Microweave information
nozzlenum=1 nozzlespacing=1 package=1 totalpasses=1 unitpixels=1
used_nozzles=1 buildup=1 builddown=1 cycle=1 numbuffers=3
Colormatch file=PRO4800photoblk; Curves=2880dpi_gloss_pro4800; Table=epson_premium
Report at end of pdrive_class::begin_page
Total memory usage=6162529
calculate_dim: print left=0 top=0 width=29376 height=14688
calculate_dim: section left=0 top=0 width=4643 height=4643
Print size in printer pixels, relative to printable area:
left=0 top=0 width=29376 height=14688
INFO: TurboPrint: printing page 1, 0% complete...
INFO: TurboPrint: printing page 1, 3% complete...
INFO: TurboPrint: printing page 1, 6% complete...
(continued...)

zedonet
Site Admin
Posts: 1831
Joined: Fri Oct 06, 2006 8:02 am

Post by zedonet » Fri Jun 08, 2007 1:18 pm

The debug output looks okay. Can you email a scan or digicam photo of the output (plus the original image)? Email: zeiler a t zedonet d o t com

Thank you!

marieeve83
Posts: 8
Joined: Fri Jun 01, 2007 5:57 pm

Re: printing borderless with lpr

Post by marieeve83 » Thu Jun 14, 2007 3:34 pm

We were finaly able to print it correctly!
I don't know exactly what was the problem, we did a lot of tests and it finally worked. We printed another image, maybe the first one was corrupted in some way... Anyway, now it is ok! Thank you for your help! :)

But there are still 3 small problems left...

The first one is that the double cut does not work correctly. The bottom cut is ok, but the top one only cuts about one quarter instead of the whole line. Do you know how we can correct this?

The second one is that there is a lot of paper lost between 2 prints (about 5 inch I think). I saw that there is something called "Save Paper", is it the option to change to waste less paper? How can I change it (in the .tpp or in the command line)?

The last problem is that the colors are not exactly what we want. If we don't select True Match, it's too dark and purple. If we select it, it is much better, but still a bit too blue (light blue) and we are loosing what is supposed to be red (it appears much too pale). Maybe it is because of the paper? Our paper is "Epson Premium Luster Photo Paper (260)" which is not it the list so I chosed "Epson Premium Glossy/Satin". Maybe I can modify a little bit the options of the paper? I saw that there are 4 parameters for each paper (ex. Param=4,13,0,0) what do they mean?

The other solution would probably be to change the color options and add more magenta and yellow. What do you suggest me to do, change the paper options or the color options?

Thank you very much!

zedonet
Site Admin
Posts: 1831
Joined: Fri Oct 06, 2006 8:02 am

Post by zedonet » Fri Jun 15, 2007 8:04 am

Hello,

I would first try to find the driver's media type that gives the best result, then adjust C/M/Y as necessary.

To compare the media settings I recommend to cut a sheet of paper from the roll and print on it several times at different positions:

tpprint .... -s4000x3000 -p0x0 -m4
tpprint .... -s4000x3000 -p4000x0 -m5
tpprint .... -s4000x3000 -p0x3000 -m6
...

this will print an image at a maximum size of 4x3 inches. The first print will go top left, the second top right, then the second line...
try media types 4,5,6 (epson glossy / premium / proof paper) and 8,9,10,11,12 (kodak / ilford / fuji / tetenal / zedonet paper). Of course the paper must be inserted again for each print.

You can print a similiar sheet with different c/m/y correction settings, e.g.

-bc20m0y0
-bc0m20y0
-bc0m0y20

I will check about the cut position - it may be possible to adjust it.

The amount of paper wasted between two prints cannot be set by the driver, but may depend on the media code sent. You can try if less paper is wasted with the setting -m6 (Epson Proof Satin).

marieeve83
Posts: 8
Joined: Fri Jun 01, 2007 5:57 pm

Post by marieeve83 » Fri Jun 15, 2007 3:34 pm

Hi,
As you suggested, I printed many tests on the same sheet of paper. It was a very good idea, it's very easy to compare the results this way!

I have tried a few media types, but the results are the same. I looked at the ppt, and I saw that the parameters of many paper types are the same as Epson Premium Glossy/Satin (Gamma=100 / Saturation=100 / Param=4,13,0,0). The Epson Proof Satin has different parameters, but the results are still the same.

I then changed the color settings (CMY, saturation, etc.), we are not yet getting exactly what we want but it is better! And we are still working on it to find the perfect settings!

marieeve83
Posts: 8
Joined: Fri Jun 01, 2007 5:57 pm

Post by marieeve83 » Fri Jun 22, 2007 12:17 pm

I have tried to print the image on an Epson Stylus Photo R220 and the results are much better! With true match, on the same paper, the colors are almost perfect.

Could it be a problem with the True Match algorithm for the Epson Stylus Pro 4800? Is there a way to change that? (other than playing with the settings in the tpprint command, which does not give us the expected results for now).

zedonet
Site Admin
Posts: 1831
Joined: Fri Oct 06, 2006 8:02 am

Post by zedonet » Fri Jun 22, 2007 2:23 pm

The Pro4800 driver should have better color accuracy than the R220 - the same profiles as in our RIP solution PrintFab for Mac OS X are used.

However, the profiles in turboprint-1.95-2 are not the final profiles. Please download

ftp://ftp.zedonet.com/turboprint-1.95-3beta.tgz

for a version with the final color profiles.

You wrote all media settings give bad results, so I suspect the problem is somewhere else. You should check if the nozzle test print from TurboPrint Config is correct (tab "Toolbox").

If you want you can email comparison scans sor digicam photos from your prints with Pro4800 and R220 to mail at zedonet dot de

marieeve83
Posts: 8
Joined: Fri Jun 01, 2007 5:57 pm

Post by marieeve83 » Thu Jun 28, 2007 1:55 pm

I installed the new version and also did a nozzle test + cleaning.

Now everything works fine!! The colors are perfect!

Since I did the two things at the same time, I don't know what did the biggest difference: the new version or the cleaning... But anyway, everything is ok now!

Thank you very much for your help!

Post Reply