Unable to setup printer under Leopard

Questions on installation
Post Reply
apples
Posts: 7
Joined: Sun Nov 18, 2007 9:02 pm

Unable to setup printer under Leopard

Post by apples »

Just got my new computer with Leopard and when add the printer, I'm unable to get it to print. I set it up the same way I had in Tiger. It looks like it's sent but nothing prints
1. LPD protocal
2. Entered IP Address
3. lp for Queue

Am I missing something new here with Leopard?

Thanks
zedonet
Site Admin
Posts: 2175
Joined: Fri Oct 06, 2006 8:02 am

Post by zedonet »

Hello,

which printer server do you have?

Problems with wireless connection to an Airport station have been reported with OS X 10.5:

http://discussions.apple.com/thread.jsp ... ID=5645535

I expect that some fix for OS X will be released.
apples
Posts: 7
Joined: Sun Nov 18, 2007 9:02 pm

Post by apples »

I have the Linksys WPS54G
zedonet
Site Admin
Posts: 2175
Joined: Fri Oct 06, 2006 8:02 am

Post by zedonet »

Hello,

is it a wireless connection?

Can you reach the router - e.g. the WEB frontend or "ping" from comandline?
apples
Posts: 7
Joined: Sun Nov 18, 2007 9:02 pm

Post by apples »

Yes I can ping it. I have a laptop that is connecting to it right now and that can print fine with PrintFab, but it's running 10.4.

The new imac is not wireless. It's going through my home network (ethernet).

Thanks
apples
Posts: 7
Joined: Sun Nov 18, 2007 9:02 pm

Post by apples »

ARGH!

I still can not print with Leopard. I have to share the printer with my laptop which works just fine but it's SLOW
platti
Posts: 7
Joined: Fri Nov 23, 2007 5:41 pm

Post by platti »

Hello,

On AirportExpress,our Canon Printer works on the HPJetdirect-Socket Protocol, but only to 99%, then there is a stop for three or four minutes. After this time the printjob will finish.
Maybe this protocol works for you.
apples
Posts: 7
Joined: Sun Nov 18, 2007 9:02 pm

Post by apples »

thanks for the tidbit, but it didn't work. got to 16% and then said it couldnt connect to rinter
zedonet
Site Admin
Posts: 2175
Joined: Fri Oct 06, 2006 8:02 am

Post by zedonet »

It seems that the "Bonjour" protocol (URI = mdns://...) doesn't work properly in Leopard.

You could try to set up the printer using a different protocol - either "HP JetDirect / Socket" or "LPD - Line Printer Daemon":

Open "System Panel" -> "Printing"
Add a new printer: Press "+", choose "IP"

Choose "HP Jetdirect - Socket" protocol, use "10.0.1.1" as IP address (= standard address of airport base station; or enter other ip address if the address has been changed). Then enter e.g. "Canon PrintFab" as manufacturer and choose your printer model.

If printing still doesn't work properly, you can also choose "LPD - Line printer daemon" protocol. Also enter "10.0.1.1" as IP address and "lp" as print queue.
apples
Posts: 7
Joined: Sun Nov 18, 2007 9:02 pm

Post by apples »

I resolved it finally. I went and purchased an Apple Airport Extreme and that solved it...thank goodness :)
Post Reply