SOLVED! - Problems printing via wireless print server

Post Reply
Posts: 1
Joined: Sun Oct 26, 2008 1:32 pm

SOLVED! - Problems printing via wireless print server

Post by porpoise1954 »


Not quite definite about what fixed it but here's what I did:

1. Found reference to the fact that the print server uses seperate MACs for the wired and wireless interfaces - I had only entered the wired MAC.

2. Thought.. Aha! the wireless MAC address is being blocked by the Belkin Router even though the wired MAC is enabled.

3. Added the print server Wireless MAC address to the filters on the Belkin router

4. Then realised, I had disabled the MAC filtering during the setup phase and had not yet re-enabled it, so it shouldn't have made any difference.

5. Re-enabled MAC filtering on router.

6. Restarted Turboprint, restarted printer - BINGO! it now works!

Go figure. I don't see how not having the MAC address in the router could make a difference when the filtering was turned off anyway but it works now that the MAC address is in the router and the filtering is turned on!??!

Still. Now that it works, I thought I would just post this info in case anyone else was having the same problems and it might help them too.


I'm having problems printing via a Netgear WGPS606 wireless print server in Ubuntu 8.04 :(

I've set up the printer (Canon Pro9000) via direct USB, which works fine. The print server is showing up on the network and is pingable. The TurboPrint Spooler shows "Connected to" which is the WGPS606's IP, and I can login to the WGPS606 via the browser with no problems, so the print server is connecting and communicating with the network just fine - it's just that I can't get TurboPrint to get the printer to actually print.

When I try to print the test page, it starts up with 'Connected to' then it changes to the error message: '/usr/lib/cups/backend/lpd failed' :cry:

Does anyone please have any ideas how I can fix this? I need the printer on wireless, as it's too big to be sited near the PC for a direct connection but, also, because I want to be able to print to it from any PC on the network without having to have one of the PCs always on for printer sharing - hence the WGPS606
Post Reply