Yosemite compatibility

Questions on installation
Post Reply
neon
Posts: 13
Joined: Thu Aug 04, 2011 7:55 am

Yosemite compatibility

Post by neon »

Hello,

i upgraded to Yosemite and now i am unable to print through PrintFab. I have the 2.63 version and a Canon PIXMA Pro9000 connected to a TP-Link TL-PS110U print server. The Canon driver works ok.
I tried to reset the printing system but with no result.
neon
Posts: 13
Joined: Thu Aug 04, 2011 7:55 am

Re: Yosemite compatibility

Post by neon »

nevermind,
i see that a new version of PrinFab appeared tonight.
neon
Posts: 13
Joined: Thu Aug 04, 2011 7:55 am

Re: Yosemite compatibility

Post by neon »

Unfortunately even the 2.70 version doesn't work correctly on Yosemite.
At first i reset the printing system to start on a clean slate, i uninstalled the 2.63 and after that i installed the 2.70. So far so good.
The first thing after that i printed a test page from the PrintFab Toolbox. I though that all is in order after the print test was alright. I reentered all my paper profiles, i remaked all my print presets. And now, after all that work i still can't print real documents. The only things that come out of the printer are the test pages from the Toolbox.
I tried Adobe apps, Preview app, nothing. The printing queue appears and the document disappears from queue and nothing on the printer side.
zedonet
Site Admin
Posts: 2191
Joined: Fri Oct 06, 2006 8:02 am

Re: Yosemite compatibility

Post by zedonet »

Hello,

I am not sure if it is a general driver problem or a problem that is specific to your print server - can you print with direct USB connection from your Mac to the printer?

Which network protocol do you use to connect to your print server (the protocol type is shown in PrintFab Toolbox, list of installed printers, right column - e.g. "socket", "ipp", "lpd")?

To determine if there is a driver problem, it would be helpful if you could send the PrintFab log file after trying to print from Preview or from Adobe Reader:

Please open a Finder window and select "Go" -> "Go to folder" from the pulldown menu. A dialog will open - type "/var/log" in the line that asks for the directory name.

Now copy the file "printfab_cups.log" from the Finder window to your "Documents" directory so that you can attach it to your email.

Please send by email to: mail at zedonet dot de
neon
Posts: 13
Joined: Thu Aug 04, 2011 7:55 am

Re: Yosemite compatibility

Post by neon »

zedonet wrote:Hello,

I am not sure if it is a general driver problem or a problem that is specific to your print server - can you print with direct USB connection from your Mac to the printer?

Which network protocol do you use to connect to your print server (the protocol type is shown in PrintFab Toolbox, list of installed printers, right column - e.g. "socket", "ipp", "lpd")?

To determine if there is a driver problem, it would be helpful if you could send the PrintFab log file after trying to print from Preview or from Adobe Reader:

Please open a Finder window and select "Go" -> "Go to folder" from the pulldown menu. A dialog will open - type "/var/log" in the line that asks for the directory name.

Now copy the file "printfab_cups.log" from the Finder window to your "Documents" directory so that you can attach it to your email.

Please send by email to: mail at zedonet dot de
as i said before, i can print without problems in the same setup with the original Canon driver. so it' appears to be a PrintFab driver problem. and if the test pages from the PrintFab Toolbox are printing ok, through the same setup, how can it be a print server problem?

the protocol is the default lpd, which worked perfectly with PrintFab on Mavericks and still works perfectly with the Canon driver on Yosemite.

I'll try to send today a log.
neon
Posts: 13
Joined: Thu Aug 04, 2011 7:55 am

Re: Yosemite compatibility

Post by neon »

zedonet wrote:Please send by email to: mail at zedonet dot de
log sent.

thank you.
zedonet
Site Admin
Posts: 2191
Joined: Fri Oct 06, 2006 8:02 am

Re: Yosemite compatibility

Post by zedonet »

Thank you for sending the log file - there was actually a Yosemite related problem with user color profiles. We have just created a new version that you can download with this link

ftp://ftp.zedonet.com/printfab/printfab-2.71.dmg

Please let me know if any problems remain.
neon
Posts: 13
Joined: Thu Aug 04, 2011 7:55 am

Re: Yosemite compatibility

Post by neon »

zedonet wrote:Thank you for sending the log file - there was actually a Yosemite related problem with user color profiles. We have just created a new version that you can download with this link

ftp://ftp.zedonet.com/printfab/printfab-2.71.dmg

Please let me know if any problems remain.
now it appears to working fine.

thank you for the fast fix.
Post Reply